libutf8-all-perl_0.015-1_all.deb


Advertisement

Description

libutf8-all-perl - Perl pragma to turn on UTF-8 everywhere

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libutf8-all-perl
Package version 0.015
Package release 1
Package architecture all
Package type deb
Installed size 57 B
Download size 11.09 KB
Official Mirror ftp.br.debian.org
The utf8 pragma allows you to write Perl source code encoded in UTF-8. That
means UTF-8 strings, variable names, and regular expressions. utf8::all goes
further, and makes @ARGV encoded in UTF-8, and filehandles are opened with
UTF-8 encoding turned on by default (including STDIN, STDOUT, STDERR). If you
don't want UTF-8 for a particular filehandle, you'll have to set binmode
$filehandle.

Alternatives

Package Version Architecture Repository
libutf8-all-perl_0.015-1_all.deb 0.015 all Debian Main
libutf8-all-perl - - -

Requires

Name Value
libautodie-perl >= 2.12
libimport-into-perl -
perl >= 5.17.2
perl -

Download

Type URL
Binary Package libutf8-all-perl_0.015-1_all.deb
Source Package libutf8-all-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libutf8-all-perl deb package:
    # sudo apt-get install libutf8-all-perl

Files

Path
/usr/share/doc/libutf8-all-perl/changelog.Debian.gz
/usr/share/doc/libutf8-all-perl/changelog.gz
/usr/share/doc/libutf8-all-perl/copyright
/usr/share/man/man3/utf8::all.3pm.gz
/usr/share/perl5/utf8/all.pm

Changelog

2014-09-08 - gregor herrmann <gregoa@debian.org>
libutf8-all-perl (0.015-1) unstable; urgency=medium
* Add debian/upstream/metadata
* Imported upstream version 0.015
* Add autopkgtest control file.
2014-08-23 - gregor herrmann <gregoa@debian.org>
libutf8-all-perl (0.013-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* New upstream release.
* Drop version from libmodule-build-perl build-dep.
2014-08-04 - gregor herrmann <gregoa@debian.org>
libutf8-all-perl (0.012-1) unstable; urgency=medium
* New upstream release.
* Strip trailing slash from metacpan URLs.
* debian/rules: drop override_dh_auto_install.
The formerly removed file is gone.
* Update years of packaging copyright.
* Drop build dependencies which are note needed anymore.
* Declare compliance with Debian Policy 3.9.5.
2013-09-13 - gregor herrmann <gregoa@debian.org>
libutf8-all-perl (0.011-1) unstable; urgency=low
* New upstream release.
* Update build and runtime dependencies.
2013-02-18 - gregor herrmann <gregoa@debian.org>
libutf8-all-perl (0.010-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Update years of packaging copyright.
* Set Standards-Version to 3.9.4 (no changes).
2012-10-27 - Salvatore Bonaccorso <carnil@debian.org>
libutf8-all-perl (0.009-1) unstable; urgency=low
* Team upload.
* Imported Upstream version 0.008 and 0.009
* Update required build-dependencies.
Add Build-Depends-Indep on libtest-fatal-perl.
Upstream updated requirement on Test::More: Add alternative
Build-Depends-Indep on perl (>= 5.13.4) | libtest-simple-perl (>= 0.96).
* Correct dependency for autodie module.
Adjust (Build-)Depends(-Indep) for autodie 2.12 to
libautodie-perl (>= 2.12) | perl (>= 5.17.2).
2012-09-15 - gregor herrmann <gregoa@debian.org>
libutf8-all-perl (0.007-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Nuno Carvalho ]
* d/control: Add new dependecies libtest-warn-perl and libimport-into-perl.
* d/control: Move dependencies to B-D-I.
* d/control: Update standards version.
* d/control: Require autodie version >= 2.12 in B-D-I.
* d/copyright: Update format and field names.
* New upstream release.
[ gregor herrmann ]
* Don't install lib/utf8/all/Conflicts.pm into the binary package; it's
only used at build time.
* debian/control: depend on autodie >= 2.12. This is not strictly
necessary but utf8::all conflicts with older versions of autodie if
they are used.
2012-01-10 - gregor herrmann <gregoa@debian.org>
libutf8-all-perl (0.004-1) unstable; urgency=low
* New upstream release.
* Update years of packaging copyright.
* Add build dependency on libtest-script-perl.
2011-12-22 - gregor herrmann <gregoa@debian.org>
libutf8-all-perl (0.003-1) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ gregor herrmann ]
* New upstream release.
* Build-depend on Module::Build 0.3601.
2011-04-21 - gregor herrmann <gregoa@debian.org>
libutf8-all-perl (0.002-1) unstable; urgency=low
* Initial release (closes: #623620).

See Also

Package Description
libutfcpp-dev_2.3.4-1_amd64.deb UTF8-CPP: UTF-8 with C++ - dev
libutfcpp-doc_2.3.4-1_all.deb UTF8-CPP: UTF-8 with C++ - dev
libutil-freebsd-9_10.1~svn273304-1_amd64.deb FreeBSD utility library
libutil-freebsd-dev_10.1~svn273304-1_amd64.deb Development files for libutil-freebsd
libuu-dev_0.5.20-3.4_amd64.deb Library for decoding/encoding several popular file encodings
libuu0_0.5.20-3.4_amd64.deb Library for decoding/encoding several popular file encodings
libuuid-perl_0.05-1+b1_amd64.deb Perl extension for using UUID interfaces as defined in e2fsprogs
libuuid-tiny-perl_1.0400-1_all.deb pure Perl module to generate v1, v3, v4, and v5 UUIDs
libuuid1_2.25.2-6_amd64.deb Universally Unique ID library
libuuidm-ocaml-dev_0.9.5-1+b1_amd64.deb Universally unique identifiers for OCaml
libuv0.10-dev_0.10.28-6_amd64.deb asynchronous event notification library - development files
libuv0.10_0.10.28-6_amd64.deb asynchronous event notification library - runtime library
libv-perl_0.13-1_all.deb module for printing the version of specified perl module(s)
libv4l-0_1.6.0-2_amd64.deb Collection of video4linux support libraries
libv4l-dev_1.6.0-2_amd64.deb Collection of video4linux support libraries (development files)
Advertisement
Advertisement