libuser-identity-perl_0.94-1_all.deb


Advertisement

Description

libuser-identity-perl - module to manage a person's identities/roles

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libuser-identity-perl
Package version 0.94
Package release 1
Package architecture all
Package type deb
Installed size 226 B
Download size 77.89 KB
Official Mirror ftp.br.debian.org
User::Identity is a Perl module that provides a set of informational classes
which are related to one user. This module attempts to be smart at providing
defaults, conversions and often required combinations.
The identities do not implement any kind of storage, so they can be used by
any Perl program. As a result, it is more flexible than an XML file to store
the data. For instance, you can choose to store the data using Data::Dumper,
Storable, DBI, AddressBook, etc.

Alternatives

Package Version Architecture Repository
libuser-identity-perl_0.94-1_all.deb 0.94 all Debian Main
libuser-identity-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libuser-identity-perl_0.94-1_all.deb
Source Package libuser-identity-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libuser-identity-perl deb package:
    # sudo apt-get install libuser-identity-perl

Files

Path
/usr/share/doc/libuser-identity-perl/changelog.Debian.gz
/usr/share/doc/libuser-identity-perl/changelog.gz
/usr/share/doc/libuser-identity-perl/copyright
/usr/share/man/man3/Mail::Identity.3pm.gz
/usr/share/man/man3/User::Identity.3pm.gz
/usr/share/man/man3/User::Identity::Archive.3pm.gz
/usr/share/man/man3/User::Identity::Archive::Plain.3pm.gz
/usr/share/man/man3/User::Identity::Collection.3pm.gz
/usr/share/man/man3/User::Identity::Collection::Emails.3pm.gz
/usr/share/man/man3/User::Identity::Collection::Locations.3pm.gz
/usr/share/man/man3/User::Identity::Collection::Systems.3pm.gz
/usr/share/man/man3/User::Identity::Collection::Users.3pm.gz
/usr/share/man/man3/User::Identity::Item.3pm.gz
/usr/share/man/man3/User::Identity::Location.3pm.gz
/usr/share/man/man3/User::Identity::System.3pm.gz
/usr/share/perl5/Mail/Identity.pm
/usr/share/perl5/Mail/Identity.pod
/usr/share/perl5/User/Identity.pm
/usr/share/perl5/User/Identity.pod
/usr/share/perl5/User/Identity/Archive.pm
/usr/share/perl5/User/Identity/Archive.pod
/usr/share/perl5/User/Identity/Collection.pm
/usr/share/perl5/User/Identity/Collection.pod
/usr/share/perl5/User/Identity/Item.pm
/usr/share/perl5/User/Identity/Item.pod
/usr/share/perl5/User/Identity/Location.pm
/usr/share/perl5/User/Identity/Location.pod
/usr/share/perl5/User/Identity/System.pm
/usr/share/perl5/User/Identity/System.pod
/usr/share/perl5/User/Identity/Archive/Plain.pm
/usr/share/perl5/User/Identity/Archive/Plain.pod
/usr/share/perl5/User/Identity/Collection/Emails.pm
/usr/share/perl5/User/Identity/Collection/Emails.pod
/usr/share/perl5/User/Identity/Collection/Locations.pm
/usr/share/perl5/User/Identity/Collection/Locations.pod
/usr/share/perl5/User/Identity/Collection/Systems.pm
/usr/share/perl5/User/Identity/Collection/Systems.pod
/usr/share/perl5/User/Identity/Collection/Users.pm
/usr/share/perl5/User/Identity/Collection/Users.pod

Changelog

2014-01-26 - Salvatore Bonaccorso <carnil@debian.org>
libuser-identity-perl (0.94-1) unstable; urgency=medium
* Team upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.94
* Update copyright for upstream files
* Update license stanzas for Artistic and GPL-1+ licenses.
Refer to Debian systems in general instead of only Debian GNU/Linux
systems.
Explicitly refer to GPL-1 text in common-licenses.
* Convert package to '3.0 (quilt)' source package format
* Declare compliance with Debian Policy 3.9.5
* Bump Debhelper compat level to 8.
Adjust the versioned Build-Depends on debhelper to (>= 8)
* Don't run POD tests in the testsuite.
Drop Build-Depends-Indep on libtest-pod-perl.
* Add spelling-error-in-manpage.patch patch.
Fixes spelling errors detected by lintian.
2009-12-25 - Jonathan Yu <jawnsy@cpan.org>
libuser-identity-perl (0.93-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Use new short debhelper rules format
* Rewrite control description
* Standards-Version 3.8.3 (drop perl version dep)
* Add myself to Uploaders and Copyright
* Refresh copyright information
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* Change my email address.
* debian/watch: remove call to uupdate.
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
2008-02-27 - gregor herrmann <gregor+debian@comodo.priv.at>
libuser-identity-perl (0.92-2) unstable; urgency=low
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Removed: XS-
Vcs-Svn fields.
* debian/rules: delete /usr/lib/perl5 only if it exists (closes: #467766).
* debian/watch: use dist-based URL.
* Set Standards-Version to 3.7.3 (no changes needed).
* Set debhelper compatibility level to 6.
* debian/rules:
- move dh_clean before make distclean
- let install-stamp target depend on build-stamp
- use $@ for touching stamp files
- remove commented out dh_installexamples and some comments/whitespace
* debian/copyright: add upstream source location, switch to new format.
* Add /me to Uploaders.
2007-08-11 - Damyan Ivanov <dmn@debian.org>
libuser-identity-perl (0.92-1) unstable; urgency=low
* New upstream release
* Added myself to Uploaders:
* Bumped debhelper compatibility level to 5. Adjusted build-dependency
accordingly
* Updated debian/copyright. Added packaging copyright and license.
* [debian/rules]
+ Don't ignore errors from $(MAKE) clean
+ Remove commented dh_installcron and dh_installmenu
* Added libtest-pod-perl to Build-Depends to enable POD tests
2007-02-28 - Gunnar Wolf <gwolf@debian.org>
libuser-identity-perl (0.91-1) unstable; urgency=low
* New upstream release
* Bumped up standards-version to 3.7.2.2 (no changes needeed)
2005-04-12 - Gunnar Wolf <gwolf@debian.org>
libuser-identity-perl (0.90-3) unstable; urgency=low
* Added debian/watch
2005-03-31 - Gunnar Wolf <gwolf@debian.org>
libuser-identity-perl (0.90-2) unstable; urgency=low
* Fixed description, as it referred only to a submodule, not to the
whole module. Thanks, Peter Samuelson, for pointing it out.
* Removed README from the doc dir, as it is just the dummy README
generated by h2xs
2005-03-30 - Gunnar Wolf <gwolf@debian.org>
libuser-identity-perl (0.90-1) unstable; urgency=low
* Initial Release (Closes: #302278)

See Also

Package Description
libuser-perl_1.9-1_all.deb Provides user data in an OS independent manner
libuser-simple-perl_1.45-1_all.deb module for simple user sessions management
libuser1-dev_0.60~dfsg-1.2_amd64.deb user and group account administration library - development files
libuser1_0.60~dfsg-1.2_amd64.deb user and group account administration library - shared libraries
libuser_0.60~dfsg-1.2_amd64.deb user and group account administration library - utilities
libustr-1.0-1_1.0.4-3+b2_amd64.deb Micro string library: shared library
libustr-dev_1.0.4-3+b2_amd64.deb Micro string library: development stuff
libustr-doc_1.0.4-3_all.deb Micro string library: documentation
libutempter-dev_1.1.5-4_amd64.deb A privileged helper for utmp/wtmp updates (development)
libutempter0_1.1.5-4_amd64.deb A privileged helper for utmp/wtmp updates (runtime)
libutf8-all-perl_0.015-1_all.deb Perl pragma to turn on UTF-8 everywhere
libutfcpp-dev_2.3.4-1_amd64.deb UTF8-CPP: UTF-8 with C++ - dev
libutfcpp-doc_2.3.4-1_all.deb UTF8-CPP: UTF-8 with C++ - dev
libutil-freebsd-9_10.1~svn273304-1_amd64.deb FreeBSD utility library
libutil-freebsd-dev_10.1~svn273304-1_amd64.deb Development files for libutil-freebsd
Advertisement
Advertisement