liburi-perl_1.64-1_all.deb


Advertisement

Description

liburi-perl - module to manipulate and access URI strings

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: liburi-perl
Package version: 1.64
Package release: 1
Package architecture: all
Package type: deb
Installed size: 229 B
Download size: 93.29 KB
Official Mirror: ftp.br.debian.org
URI is a collection of Perl modules that represent and manipulate Uniform Resource Identifier (URI) references as specified in RFC 2396. URI objects can be used to access and manipulate the various components that make up these strings. There are also methods to combine URIs in various ways. The URI class replaces the URI::URL class that used to be distributed with libwww-perl. This package also includes an emulation of the old URI::URL interface, which implements both the old and the new interface.

Alternatives

Requires

    Download

    Source package: liburi-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liburi-perl deb package:
      # sudo apt-get install liburi-perl

    Files

    • /usr/share/doc/liburi-perl/changelog.Debian.gz
    • /usr/share/doc/liburi-perl/changelog.gz
    • /usr/share/doc/liburi-perl/copyright
    • /usr/share/man/man3/URI.3pm.gz
    • /usr/share/man/man3/URI::Escape.3pm.gz
    • /usr/share/man/man3/URI::Heuristic.3pm.gz
    • /usr/share/man/man3/URI::QueryParam.3pm.gz
    • /usr/share/man/man3/URI::Split.3pm.gz
    • /usr/share/man/man3/URI::URL.3pm.gz
    • /usr/share/man/man3/URI::WithBase.3pm.gz
    • /usr/share/man/man3/URI::_punycode.3pm.gz
    • /usr/share/man/man3/URI::data.3pm.gz
    • /usr/share/man/man3/URI::file.3pm.gz
    • /usr/share/man/man3/URI::ldap.3pm.gz
    • /usr/share/perl5/URI.pm
    • /usr/share/perl5/URI/Escape.pm
    • /usr/share/perl5/URI/Heuristic.pm
    • /usr/share/perl5/URI/IRI.pm
    • /usr/share/perl5/URI/QueryParam.pm
    • /usr/share/perl5/URI/Split.pm
    • /usr/share/perl5/URI/URL.pm
    • /usr/share/perl5/URI/WithBase.pm
    • /usr/share/perl5/URI/_foreign.pm
    • /usr/share/perl5/URI/_generic.pm
    • /usr/share/perl5/URI/_idna.pm
    • /usr/share/perl5/URI/_ldap.pm
    • /usr/share/perl5/URI/_login.pm
    • /usr/share/perl5/URI/_punycode.pm
    • /usr/share/perl5/URI/_query.pm
    • /usr/share/perl5/URI/_segment.pm
    • /usr/share/perl5/URI/_server.pm
    • /usr/share/perl5/URI/_userpass.pm
    • /usr/share/perl5/URI/data.pm
    • /usr/share/perl5/URI/file.pm
    • /usr/share/perl5/URI/ftp.pm
    • /usr/share/perl5/URI/gopher.pm
    • /usr/share/perl5/URI/http.pm
    • /usr/share/perl5/URI/https.pm
    • /usr/share/perl5/URI/ldap.pm
    • /usr/share/perl5/URI/ldapi.pm
    • /usr/share/perl5/URI/ldaps.pm
    • /usr/share/perl5/URI/mailto.pm
    • /usr/share/perl5/URI/mms.pm
    • /usr/share/perl5/URI/news.pm
    • /usr/share/perl5/URI/nntp.pm
    • /usr/share/perl5/URI/pop.pm
    • /usr/share/perl5/URI/rlogin.pm
    • /usr/share/perl5/URI/rsync.pm
    • /usr/share/perl5/URI/rtsp.pm
    • /usr/share/perl5/URI/rtspu.pm
    • /usr/share/perl5/URI/sip.pm
    • /usr/share/perl5/URI/sips.pm
    • /usr/share/perl5/URI/snews.pm
    • /usr/share/perl5/URI/ssh.pm
    • /usr/share/perl5/URI/telnet.pm
    • /usr/share/perl5/URI/tn3270.pm
    • /usr/share/perl5/URI/urn.pm
    • /usr/share/perl5/URI/file/Base.pm
    • /usr/share/perl5/URI/file/FAT.pm
    • /usr/share/perl5/URI/file/Mac.pm
    • /usr/share/perl5/URI/file/OS2.pm
    • /usr/share/perl5/URI/file/QNX.pm
    • /usr/share/perl5/URI/file/Unix.pm
    • /usr/share/perl5/URI/file/Win32.pm
    • /usr/share/perl5/URI/urn/isbn.pm
    • /usr/share/perl5/URI/urn/oid.pm

    Changelog

    2014-07-20 - gregor herrmann <gregoa@debian.org> liburi-perl (1.64-1) unstable; urgency=medium [ Angel Abad ] * Imported Upstream version 1.63 [ gregor herrmann ] * New upstream release 1.64. * Drop unversioned 'perl' from Depends. * Build-depend on Test::More 0.96.

    2014-07-12 - Angel Abad <angel@debian.org> liburi-perl (1.62-1) unstable; urgency=medium * Imported Upstream version 1.62 * debian/copyright: Update copyright years.

    2014-07-05 - gregor herrmann <gregoa@debian.org> liburi-perl (1.61-1) unstable; urgency=low [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. * Update years of packaging copyright and Upstream-Contact. * Declare compliance with Debian Policy 3.9.5.

    2012-03-27 - Alessandro Ghedini <al3xbio@gmail.com> liburi-perl (1.60-1) unstable; urgency=low * Team upload [ Angel Abad ] * Email change: Angel Abad -> angel@debian.org [ Alessandro Ghedini ] * New upstream release * Update debian/copyright format as in Debian Policy 3.9.3 * Bump Standards-Version to 3.9.3

    2011-08-17 - Angel Abad <angelabad@gmail.com> liburi-perl (1.59-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * [packagecheck] fixed Vcs-(Git|Browser)/Homepage field(s) in debian/control and/or URL in debian/watch and/or rmdir /usr/{lib|share}/perl5 in debian/rules. [ Angel Abad ] * Imported Upstream version 1.59 * Bump Standards-Version to 3.9.2 (no changes) * debian/copyright: Update years * Bump debhelper compatibility level to 8

    2011-01-23 - Angel Abad <angelabad@gmail.com> liburi-perl (1.58-1) unstable; urgency=low * New upstream release

    2011-01-22 - Angel Abad <angelabad@gmail.com> liburi-perl (1.57-1) unstable; urgency=low * New upstream release

    2010-10-25 - gregor herrmann <gregoa@debian.org> liburi-perl (1.56-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release: - Don't depend on DNS for the heuristics test (closes: #601116)

    2010-09-03 - Angel Abad <angelabad@gmail.com> liburi-perl (1.55-1) unstable; urgency=low * New upstream release * Add myself to Uploaders * Update copyright file * Bump Standards-Version to 3.9.1 (no changes)

    2010-04-01 - gregor herrmann <gregoa@debian.org> liburi-perl (1.54-1) unstable; urgency=low * New upstream release. * Add /me to Uploaders.

    Advertisement
    Advertisement