libuniversal-require-perl_0.17-1_all.deb


Advertisement

Description

libuniversal-require-perl - Load modules from a variable

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libuniversal-require-perl
Package version: 0.17
Package release: 1
Package architecture: all
Package type: deb
Installed size: 52 B
Download size: 9.45 KB
Official Mirror: ftp.br.debian.org
This works exactly like the standard require in Perl, except without the bareword restriction, and it does not die. Since require() is placed in the UNIVERSAL namespace, it will work on any module. You just have to use UNIVERSAL::require somewhere in your code. If you have ever had to do this... eval "require $module"; to get around the bareword caveats on require(), this module is for you. It creates a universal require() class method that will work with every Perl module and it is secure. So instead of doing some arcane eval() work, you can do this: $module->require; It does not save you much typing, but it will make a lot more sense to someone who is not a ninth level Perl acolyte. Also provided is a use() method which works in a similar way.

Alternatives

Requires

Replaces

  • libuniversal-exports-perl

    Download

    Source package: libuniversal-require-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libuniversal-require-perl deb package:
      # sudo apt-get install libuniversal-require-perl

    Files

    • /usr/share/doc/libuniversal-require-perl/changelog.Debian.gz
    • /usr/share/doc/libuniversal-require-perl/changelog.gz
    • /usr/share/doc/libuniversal-require-perl/copyright
    • /usr/share/man/man3/UNIVERSAL::require.3pm.gz
    • /usr/share/perl5/UNIVERSAL/require.pm

    Changelog

    2014-04-22 - Florian Schlichting <fsfs@debian.org> libuniversal-require-perl (0.17-1) unstable; urgency=low [ Florian Schlichting ] * Import Upstream version 0.15, 0.16, 0.17 * Drop spelling.patch, applied upstream * Declare compliance with Debian Policy 3.9.5 * Bump years of packaging copyright [ Daniel Lintott ] * Correct homepage URL and drop trailing slash

    2013-09-19 - Florian Schlichting <fsfs@debian.org> libuniversal-require-perl (0.14-1) unstable; urgency=low [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg- copyright" [ Florian Schlichting ] * Import Upstream version 0.14 * Bump dh compatibility to level 8 (no changes necessary) * Bump Standards-Version to 3.9.4 (directly link GPL-1) * Switch to source format 3.0 (quilt) * Switch to short-form debian/rules * New spelling.patch * Add myself to uploaders and copyright

    2009-04-03 - AGOSTINI Yves <agostini@univ-metz.fr> libuniversal-require-perl (0.13-1) unstable; urgency=low [ gregor herrmann ] * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). * debian/control: Added: ${misc:Depends} to Depends: field. [ AGOSTINI Yves ] * New upstream release * Bump to Standards-Version: 3.8.1 * Refresh rules to dh7 * Fix copyright format

    2008-05-01 - gregor herrmann <gregoa@debian.org> libuniversal-require-perl (0.11-1) unstable; urgency=low [ AGOSTINI Yves ] * Take over for the Debian Perl Group on maintainer's request (sjq@debian.org) "Thu, 1 May 2008 05:40:25 -0700 I don't have a lot of time for Debian work at the moment so I'm more than happy for the Debian Perl Group to take over maintaining libuniversal-require-perl. " * fix watch in version 3 and cpan dist * fix copyright format * fix control with standards version: 3.7.3 * upgrade to 0.11 upstream (Closes: #432490) [ gregor herrmann ] * Refresh debian/rules, no functional changes. * Bring debian/compat and the versioned dependency on debhelper in line. * Add /me to Uploaders.

    2005-11-07 - Stephen Quinney <sjq@debian.org> libuniversal-require-perl (0.10-1) unstable; urgency=low * Initial Release, closes: #333309.

    Advertisement
    Advertisement