libuniversal-moniker-perl_0.08-7_all.deb


Advertisement

Description

libuniversal-moniker-perl - Methods to output nicer names for your Perl modules/classes

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libuniversal-moniker-perl
Package version: 0.08
Package release: 7
Package architecture: all
Package type: deb
Installed size: 47 B
Download size: 7.22 KB
Official Mirror: ftp.br.debian.org
Class names in Perl often don't sound great when spoken, or look good when written in prose. For this reason, the module authors tend to say things like "customer" or "basket" when they are referring to "My::Site::User::Customer" or "My::Site::Shop::Basket". They thought it would be nice if their classes knew what they would prefer to call them. This module will add a "moniker" (and "plural_moniker") method to "UNIVERSAL", and so to every class or module.

Alternatives

Requires

    Download

    Source package: libuniversal-moniker-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libuniversal-moniker-perl deb package:
      # sudo apt-get install libuniversal-moniker-perl

    Files

    • /usr/share/doc/libuniversal-moniker-perl/changelog.Debian.gz
    • /usr/share/doc/libuniversal-moniker-perl/changelog.gz
    • /usr/share/doc/libuniversal-moniker-perl/copyright
    • /usr/share/man/man3/UNIVERSAL::moniker.3pm.gz
    • /usr/share/perl5/UNIVERSAL/moniker.pm

    Changelog

    2013-03-09 - Axel Beckert <abe@debian.org> libuniversal-moniker-perl (0.08-7) unstable; urgency=low [ gregor herrmann ] * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza). [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) [ Axel Beckert ] * Remove Bart from Uploaders (thanks for your work!), add myself to Uploaders. (Closes: #702592) * Clarify short package description. * Switch to source format "3.0 (quilt)" + Change local modification of moniker.pm into quilt patch * Switch to dh7 style rules file (fixes lintian warning debian-rules-uses-deprecated-makefile) * Bump Standards-Version to 3.9.3 (no further changes) * Fixed the following lintian warnings: + using-first-person-in-description + copyright-refers-to-symlink-license * Switch homepage to metacpan.org

    2009-06-09 - Bart Martens <bartm-perl@knars.be> libuniversal-moniker-perl (0.08-6) unstable; urgency=low * Handing over this package to Debian Perl Group. * Fixed debhelper-but-no-misc-depends. * debian/watch: Updated.

    2007-12-11 - Bart Martens <bartm@debian.org> libuniversal-moniker-perl (0.08-5) unstable; urgency=low * debian/control: Fixed description-contains-homepage. * moniker.pm: Fixed manpage-has-bad-whatis-entry.

    2006-11-16 - Bart Martens <bartm@knars.be> libuniversal-moniker-perl (0.08-4) unstable; urgency=low * New maintainer, as agreed with Stephen. * debian/*: Repackaged with cdbs. * debian/watch: Updated to version 3.

    2006-10-17 - Stephen Quinney <sjq@debian.org> libuniversal-moniker-perl (0.08-3) unstable; urgency=low * debian/control - Switched to my debian.org email address

    2005-06-11 - Stephen Quinney <sjq@debian.org> libuniversal-moniker-perl (0.08-2) unstable; urgency=low * debian/watch - Updated URL to stop lookups randomly failing.

    2004-07-31 - Stephen Quinney <sjq@debian.org> libuniversal-moniker-perl (0.08-1) unstable; urgency=low * New upstream release - small fix to prevent some warnings. * debian/rules - tidied slightly * debian/control - Updated to Standards-Version 3.6.1.1

    2004-02-25 - Stephen Quinney <sjq@debian.org> libuniversal-moniker-perl (0.07-1) unstable; urgency=low * New upstream release - performance improvement. * Now just recommend Lingua::EN::Inflect instead of depending. * Updated copyright file. * Added in the upstream Changes file.

    2003-09-08 - Stephen Quinney <sjq@debian.org> libuniversal-moniker-perl (0.06-1) unstable; urgency=low * New upstream release - make the tests work if the optional module Lingua::EN::Inflect is not installed.

    2003-09-05 - Stephen Quinney <sjq@debian.org> libuniversal-moniker-perl (0.05-1) unstable; urgency=low * New upstream release.

    Advertisement
    Advertisement