libuniversal-exports-perl_0.05-2_all.deb


Advertisement

Description

libuniversal-exports-perl - module for lightweight, universal variable exporting

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libuniversal-exports-perl
Package version 0.05
Package release 2
Package architecture all
Package type deb
Installed size 60 B
Download size 7.62 KB
Official Mirror ftp.br.debian.org
UNIVERSAL::exports is an alternative to the Perl Exporter module, providing a
universal, lightweight subset of its functionality. It uses Exporter::Lite
(see libexporter-lite-perl for details).
Historically, this module provided UNIVERSAL::require, which has become an
independent distribution. For reasons of backward compatibility, this package
depends on libuniversal-require-perl.

Alternatives

Package Version Architecture Repository
libuniversal-exports-perl_0.05-2_all.deb 0.05 all Debian Main
libuniversal-exports-perl - - -

Requires

Name Value
libexporter-lite-perl -
libuniversal-require-perl -
perl -

Download

Type URL
Binary Package libuniversal-exports-perl_0.05-2_all.deb
Source Package libuniversal-exports-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libuniversal-exports-perl deb package:
    # sudo apt-get install libuniversal-exports-perl

Files

Path
/usr/share/doc/libuniversal-exports-perl/changelog.Debian.gz
/usr/share/doc/libuniversal-exports-perl/changelog.gz
/usr/share/doc/libuniversal-exports-perl/copyright
/usr/share/man/man3/UNIVERSAL::exports.3pm.gz
/usr/share/perl5/UNIVERSAL/exports.pm

Changelog

2010-03-07 - Jonathan Yu <jawnsy@cpan.org>
libuniversal-exports-perl (0.05-2) unstable; urgency=low
* Adopt this package (Closes: #572531)
* Standards-Version 3.8.4 (drop perl version dep)
* Update to new short debhelper 7 rules format
* Refresh copyright to new DEP5 format
* Rewrite control description
* Update watch location (use dist URL, not author URL)
2006-10-13 - Stephen Quinney <sjq@debian.org>
libuniversal-exports-perl (0.05-1) unstable; urgency=low
* New upstream release
* debian/control: Moved debhelper to Build-Depends
2006-01-02 - Stephen Quinney <sjq@debian.org>
libuniversal-exports-perl (0.03-8) unstable; urgency=low
* Removed files which conflict with libuniversal-require-perl and now
depend on that package instead, closes: #344018.
* Switched to my debian.org address.
2005-01-14 - Stephen Quinney <sjq@debian.org>
libuniversal-exports-perl (0.03-7) unstable; urgency=low
* New maintainer, closes: #289432.
* debian/control:
* Updated to latest Standards-Version
* Updated debhelper build-dependency to >= 4
* Changed Section to perl
* debian/compat - Added in-line with current best practice
* debian/rules  - Changed to my standard file
* debian/copyright - Tidied up
* debian/watch - Added
2002-08-09 - Dagfinn Ilmari Mannsaker <ilmari@ping.uio.no>
libuniversal-exports-perl (0.03-6) unstable; urgency=low
* Build-Depends-Indep: libexporter-lite-perl
2002-08-09 - Dagfinn Ilmari Mannsaker <ilmari@ping.uio.no>
libuniversal-exports-perl (0.03-5) unstable; urgency=low
* Really fix debian/copyright
2002-07-24 - Dagfinn Ilmari Mannsaker <ilmari@ping.uio.no>
libuniversal-exports-perl (0.03-4) unstable; urgency=low
* debian/copyright: Add pointers to full license texts.
2002-07-18 - Dagfinn Ilmari Mannsaker <ilmari@ping.uio.no>
libuniversal-exports-perl (0.03-3) unstable; urgency=low
* Included copyright statement and license.
2002-07-16 - Dagfinn Ilmari Mannsaker <ilmari@ping.uio.no>
libuniversal-exports-perl (0.03-2) unstable; urgency=low
* Close ITP. (Closes: #153149)
* Removed pointless README.Debian.
* debian/changelog: Removed "Local Variables" section.
* debian/rules: Removed cruft from dh-make
2002-07-16 - Dagfinn Ilmari Mannsaker <ilmari@ping.uio.no>
libuniversal-exports-perl (0.03-1) unstable; urgency=low
* Initial Release.

See Also

Package Description
libuniversal-isa-perl_1.20140927-1_all.deb safer version of UNIVERSAL::isa
libuniversal-moniker-perl_0.08-7_all.deb Methods to output nicer names for your Perl modules/classes
libuniversal-require-perl_0.17-1_all.deb Load modules from a variable
libunix-configfile-perl_0.6-1_all.deb Perl interface to various Unix configuration files
libunix-mknod-perl_0.04-1+b3_amd64.deb Perl extension for mknod, major, minor, and makedev
libunix-syslog-perl_1.1-2+b4_amd64.deb Perl interface to the UNIX syslog(3) calls
libunixsocket-java_0.7.3-1_amd64.deb Unix socket API and bindings for Java
libunshield-dev_1.0-1_amd64.deb development files for libunshield
libunshield0_1.0-1_amd64.deb library to extract CAB files from InstallShield installers
libunwind-dev_1.1-3.2_amd64.deb library to determine the call-chain of a program - development
libunwind-setjmp0-dev_1.1-3.2_amd64.deb libunwind-based non local goto - development
libunwind-setjmp0_1.1-3.2_amd64.deb libunwind-based non local goto - runtime
libunwind8-dev_1.1-3.2_amd64.deb library to determine the call-chain of a program - development
libunwind8_1.1-3.2_amd64.deb library to determine the call-chain of a program - runtime
libupnp-dev_1.6.19+git20141001-1+deb8u1_all.deb Portable SDK for UPnP Devices (development files)
Advertisement
Advertisement