libtree-dagnode-perl_1.22-1_all.deb


Advertisement

Description

libtree-dagnode-perl - Perl (super)class for representing nodes in a tree

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtree-dagnode-perl
Package version: 1.22
Package release: 1
Package architecture: all
Package type: deb
Installed size: 173 B
Download size: 58.09 KB
Official Mirror: ftp.br.debian.org
Tree::DAG_Node is a (super)class for representing nodes in a tree. This class encapsulates/makes/manipulates objects that represent nodes in a tree structure. The tree structure is not an object itself, but is emergent from the linkages you create between nodes. This class provides the methods for making linkages that can be used to build up a tree, while preventing you from ever making any kinds of linkages which are not allowed in a tree (such as having a node be its own mother or ancestor, or having a node have two mothers).

Alternatives

    Download

    Source package: libtree-dagnode-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtree-dagnode-perl deb package:
      # sudo apt-get install libtree-dagnode-perl

    Files

    • /usr/share/doc/libtree-dagnode-perl/changelog.Debian.gz
    • /usr/share/doc/libtree-dagnode-perl/changelog.gz
    • /usr/share/doc/libtree-dagnode-perl/copyright
    • /usr/share/man/man3/Tree::DAG_Node.3pm.gz
    • /usr/share/perl5/Tree/DAG_Node.pm

    Changelog

    2014-03-03 - gregor herrmann <gregoa@debian.org> libtree-dagnode-perl (1.22-1) unstable; urgency=low * Team upload. * New upstream release. * Change (build) dependency from File::Slurp to File::Slurp::Tiny. * Declare compliance with Debian Policy 3.9.5. * Strip trailing slash from metacpan URLs.

    2013-09-17 - Xavier Guimard <x.guimard@free.fr> libtree-dagnode-perl (1.17-1) unstable; urgency=low * Imported Upstream version 1.17

    2013-09-16 - Xavier Guimard <x.guimard@free.fr> libtree-dagnode-perl (1.16-1) unstable; urgency=low * Imported Upstream version 1.16 * Replace upstream contact by Ron Savage * Require version 5.17.10 of perl to have File::Temp 0.23 * Remove libmodule-build-perl dependency * Add libfile-slurp-perl in dependencies

    2013-07-08 - Xavier Guimard <x.guimard@free.fr> libtree-dagnode-perl (1.12-1) unstable; urgency=low * Imported Upstream version 1.12

    2013-05-19 - Xavier Guimard <x.guimard@free.fr> libtree-dagnode-perl (1.11-1) unstable; urgency=low [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ Xavier Guimard ] * Update debian/watch * Imported Upstream version 1.11 * Update source format to 3.0 (quilt) * Update debian/rules to use "dh $@" * Bump debian/copyright format to 1.0 * Bump Standards-Version to 3.9.4 * Bump debhelper compatibility to 8 * Update description

    2008-01-13 - Roberto C. Sanchez <roberto@debian.org> libtree-dagnode-perl (1.06-1) unstable; urgency=low [ gregor herrmann ] * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). * Set Maintainer to Debian Perl Group. * Use dist-based URL in debian/watch. * debian/rules: delete /usr/lib/perl5 only if it exists. [ Rene Mayorga ] * New upstream release * debian/control + set Standards-version to 3.7.3 (no changes requiered) + change debhelper version to 6.0.0 + Add Build-Depends and move debhelper to there + Add ${misc:Depends} to Depends * debian/copyright: Add copyright note from upstream * debian/docs removed * debian/rules + use dh_listpackage to get the pacagke name + add build-stamp and install stamp + de-ignore ouput from make clean + remove un-used dh_calls + add make test + touch build/install-stamps

    2005-01-17 - Jay Bonci <jaybonci@debian.org> libtree-dagnode-perl (1.05-1) unstable; urgency=low * New upstream version

    2004-10-11 - Jay Bonci <jaybonci@debian.org> libtree-dagnode-perl (1.04-2) unstable; urgency=low * Adds debian/watch file so uscan will work

    2003-11-11 - Jay Bonci <jaybonci@debian.org> libtree-dagnode-perl (1.04-1) unstable; urgency=low * Initial Release. (Closes: #220287)

    Advertisement
    Advertisement