libtomcrypt0_1.17-6_amd64.deb


Advertisement

Description

libtomcrypt0 - public domain open source cryptographic toolkit

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libtomcrypt0
Package version 1.17
Package release 6
Package architecture amd64
Package type deb
Installed size 794 B
Download size 316.08 KB
Official Mirror ftp.br.debian.org
LibTomCrypt is a well documented, public domain open source crypthographic
toolkit written in C. It supports lots of block ciphers (Blowfish, Twofish,
AES, XTEA, ...), chaining modes (ECB, CBC, OFB, CFB, CTR, ...), hash functions
(MD5, SHA-1, SHA-256, RIPE-MD, ...), HMAC mechanisms, pseudo-random number
generators and public key algorithms. It has several optimizations for the
i386, x86_64 and ppc32 architectures.

Alternatives

Package Version Architecture Repository
libtomcrypt0_1.17-6_i386.deb 1.17 i386 Debian Main
libtomcrypt0 - - -

Requires

Name Value
libc6 >= 2.14
libgmp10 -
libtommath0 -
multiarch-support -

Download

Type URL
Binary Package libtomcrypt0_1.17-6_amd64.deb
Source Package libtomcrypt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtomcrypt0 deb package:
    # sudo apt-get install libtomcrypt0

Files

Path
/usr/lib/x86_64-linux-gnu/libtomcrypt.so.0
/usr/lib/x86_64-linux-gnu/libtomcrypt.so.0.0.117
/usr/share/doc/libtomcrypt0/changelog.Debian.gz
/usr/share/doc/libtomcrypt0/changelog.gz
/usr/share/doc/libtomcrypt0/copyright

Changelog

2014-09-29 - Michael Stapelberg <stapelberg@debian.org>
libtomcrypt (1.17-6) unstable; urgency=medium
* Add Build-Dependency on libtool-bin (Closes: #761769)
* Add “s” to “architectures” in package description (Closes: #755755)
2014-01-04 - Michael Stapelberg <stapelberg@debian.org>
libtomcrypt (1.17-5) unstable; urgency=low
* add patches:
- deterministic-latex.patch (Closes: #734109)
2014-01-02 - Michael Stapelberg <stapelberg@debian.org>
libtomcrypt (1.17-4) unstable; urgency=low
* Acknowledge previous two NMUs.
* Update Homepage URL to libtom.org (Closes: #732779)
* Put packaging into git on collab-maint
* Remove obsolete DM-Upload-Allowed field from debian/control
* Email change: Michael Stapelberg -> stapelberg@debian.org
* Use 3.0 (quilt) package format
* add patches:
- fix-clean-target.patch
- add-pkgconfig-file.patch
- dont-build-testprof.patch
- verbose-build-logs.patch
- respect-ldflags.patch
- x32-fixes.patch (Closes: #732780)
* Use debhelper 9 and dh(1)
* (re-)build documentation
* Fix libtomcrypt-dev package description
* Add debian/watch file and debian/upstream-signing-key.pgp
* Add doc-base file
* Bump standards-version to 3.9.5.0 (no changes necessary)
* Convert to multi-arch
* Enable hardening
2011-06-26 - Luk Claes <luk@debian.org>
libtomcrypt (1.17-3.2) unstable; urgency=low
* Non-maintainer upload.
* Don't ship .la files (Closes: #622552).
2011-03-17 - Steve M. Robbins <smr@debian.org>
libtomcrypt (1.17-3.1) unstable; urgency=low
* NMU.  Change dependency libgmp3-dev --> libgmp-dev.
2011-01-12 - Michael Stapelberg <michael@stapelberg.de>
libtomcrypt (1.17-3) unstable; urgency=low
* Define -DLTM_DESC to enable the libtommath functions
(Thanks Cezary and Pali)
* Add ${misc:Depends}
* Bump standards-version
2009-11-29 - Michael Stapelberg <michael@stapelberg.de>
libtomcrypt (1.17-2) unstable; urgency=low
* Define -DGMP_DESC to use the gmp3 arithmetic library. This makes most
crypto functions of libtomcrypt actually useful. (Thanks Alexander)
* Bump standards-version
2009-06-03 - Michael Stapelberg <michael@stapelberg.de>
libtomcrypt (1.17-1) unstable; urgency=low
* Initial release (Closes: #522966)

See Also

Package Description
libtommath-dev_0.42.0-1.1_amd64.deb multiple-precision integer library [development files]
libtommath-docs_0.42.0-1.1_all.deb multiple-precision integer library [documentation]
libtommath0_0.42.0-1.1_amd64.deb multiple-precision integer library [runtime]
libtomoyotools3_2.5.0-20140601-1_amd64.deb lightweight Linux Mandatory Access Control system - library
libtonezone-dev_2.10.0.1-1_amd64.deb tonezone library (development)
libtonezone2.0_2.10.0.1-1_amd64.deb tonezone library (runtime)
libtool-bin_2.4.2-1.11+b1_amd64.deb Generic library support script (libtool binary)
libtool-doc_2.4.2-1.11_all.deb Generic library support script
libtool_2.4.2-1.11_all.deb Generic library support script
libtoolkit-perl_0.0.2-1_all.deb Keep your handy modules organized
libtools-cli-clojure_0.2.4-2_all.deb command line argument parser for Clojure
libtools-logging-clojure_0.2.3-4_all.deb Logging macros for Clojure
libtools-macro-clojure_0.1.1-2_all.deb Clojure tools for writing macros
libtophide-ocaml-dev_1.0.1-2_all.deb hide values that start with '_' in OCaml toplevel
libtorch3-dev_3.1-2.1_amd64.deb State of the art machine learning library - development files
Advertisement
Advertisement