libtest-yaml-valid-perl_0.04-1_all.deb


Advertisement

Description

libtest-yaml-valid-perl - module to test for valid YAML

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-yaml-valid-perl
Package version: 0.04
Package release: 1
Package architecture: all
Package type: deb
Installed size: 68 B
Download size: 8.84 KB
Official Mirror: ftp.br.debian.org
Test::YAML::Valid is a Perl module that allows developers to easily test the validity of arbitrary data structures serialized using YAML (YAML Ain't a Markup Language). It provides a simple interface compatible for use with most Test::Builder-based tests.

Alternatives

Requires

    Download

    Source package: libtest-yaml-valid-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-yaml-valid-perl deb package:
      # sudo apt-get install libtest-yaml-valid-perl

    Files

    • /usr/share/doc/libtest-yaml-valid-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-yaml-valid-perl/changelog.gz
    • /usr/share/doc/libtest-yaml-valid-perl/copyright
    • /usr/share/man/man3/Test::YAML::Valid.3pm.gz
    • /usr/share/perl5/Test/YAML/Valid.pm

    Changelog

    2010-01-09 - Jonathan Yu <jawnsy@cpan.org> libtest-yaml-valid-perl (0.04-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Standards-Version 3.8.3 (drop perl version dep) * Drop version deps where satisfied by oldstable * Add myself to Uploaders and Copyright * Rewrite control description * Update copyright to new DEP5 format * Use new short debhelper 7 rules format * Add other uploaders to copyright for debian/ * Add copyright information for Module::Install * Add other implementations of YAML parsers to B-D-I for more complete test coverage * YAML::Syck is now Recommends rather than Depends, since only the YAML module is strictly necessary * Recommend different YAML implementations based on preference: YAML::Syck, YAML::XS then YAML::Tiny [ gregor herrmann ] * debian/control: require debhelper 7.2.13 because of Module::AutoInstall.

    2009-01-07 - gregor herrmann <gregoa@debian.org> libtest-yaml-valid-perl (0.03-2) unstable; urgency=low [ David Paleino ] * debian/control: - removed myself from Uploaders (Closes: #509501) - Standards-Version 3.8.0 (no changes needed) [ gregor herrmann ] * debian/control: - switch Vcs-Browser field to ViewSVN - add /me to Uploaders - improve short and long description - add libtest-pod-perl, libtest-pod-coverage-perl to Build-Depends-Indep * Don't install README anymore. * debian/copyright: add "header" section. * Set debhelper compatibility level to 7; adapt debian/{control,compat,rules}.

    2007-12-27 - Gunnar Wolf <gwolf@debian.org> libtest-yaml-valid-perl (0.03-1) unstable; urgency=low [ David Paleino ] * Initial Release (Closes: #457627) [ Gunnar Wolf ] * Removed dh-make-perl boilerplate from debian/copyright * Added myself as uploader

    Advertisement
    Advertisement