libtest-www-mechanize-perl_1.42-1_all.deb


Advertisement

Description

libtest-www-mechanize-perl - module for testing web applications

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-www-mechanize-perl
Package version: 1.42
Package release: 1
Package architecture: all
Package type: deb
Installed size: 103 B
Download size: 25.36 KB
Official Mirror: ftp.br.debian.org
Test::WWW::Mechanize is a Perl module framework for testing web applications. It extends the functionality of WWW::Mechanize (see libwww-mechanize-perl) by subclassing it, providing additional features for testing web applications. In particular, it provides much nicer diagnostics upon failure.

Alternatives

    Download

    Source package: libtest-www-mechanize-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-www-mechanize-perl deb package:
      # sudo apt-get install libtest-www-mechanize-perl

    Files

    • /usr/share/doc/libtest-www-mechanize-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-www-mechanize-perl/changelog.gz
    • /usr/share/doc/libtest-www-mechanize-perl/copyright
    • /usr/share/man/man3/Test::WWW::Mechanize.3pm.gz
    • /usr/share/perl5/Test/WWW/Mechanize.pm

    Changelog

    2012-06-04 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-perl (1.42-1) unstable; urgency=low * New upstream release. * Make build dependency on libhtml-lint-perl versioned and add it to Recommends.

    2012-04-23 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-perl (1.40-1) unstable; urgency=low [ Ansgar Burchardt ] * New upstream release 1.38. [ gregor herrmann ] * Add a Pre-Depends on dpkg (>= 1.15.6~) for the xz compression. * New upstream release 1.40. * debian/copyright: update to Copyright-Format 1.0. * Update years of upstream and packaging copyright. * Bump Standards-Version to 3.9.3 (no changes). * Build-depend on Test::More 0.96.

    2011-10-27 - Ansgar Burchardt <ansgar@debian.org> libtest-www-mechanize-perl (1.36-1) unstable; urgency=low * New upstream release. * Use XZ compression for source and binary packages. * debian/control: Convert Vcs-* fields to Git.

    2011-07-08 - Fabrizio Regalli <fabreg@fabreg.it> libtest-www-mechanize-perl (1.34-1) unstable; urgency=low [ Fabrizio Regalli ] * New upstream release. * Added myself to Uploaders and Copyright. [ gregor herrmann ] * debian/rules: unset http_proxy for tests.

    2011-05-23 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-perl (1.32-1) unstable; urgency=low * New upstream release (closes: #627177). * Remove patch 01-new-test-longstring.patch, not needed anymore. * Update years of upstream an packaging copyright. * Bump (build) dependencies on libtest-longstring-perl, libwww-mechanize-perl, add perl as an alternative to libcgi-pm-perl, add libwww-perl. * Set Standards-Version to 3.9.2 (no changes).

    2011-02-17 - Peter Pentchev <roam@ringlet.net> libtest-www-mechanize-perl (1.30-2) unstable; urgency=low [ Ansgar Burchardt ] * Update my email address. [ Peter Pentchev ] * Add the 01-new-test-longstring patch to fix the tests with recent versions of libtest-longstring-perl. Closes: #613731 * Add myself to the list of uploaders. * Refresh the copyright file a bit: - refer to the GPL-1 file and not the GPL symlink - refer to Debian systems in general - convert to the latest DEP 5 candidate format - add my copyright notice * Unversion the libwww-mechanize-perl dependency - even Lenny has it. * Bump the debhelper compatibility level to 8 with no changes. * Bump Standards-Version to 3.9.1 with no changes.

    2010-06-12 - Ansgar Burchardt <ansgar@43-1.org> libtest-www-mechanize-perl (1.30-1) unstable; urgency=low * New upstream release.

    2010-04-28 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-perl (1.28-2) unstable; urgency=low * Build depend on libcgi-pm-perl >= 3.49 (closes: #578801).

    2010-04-17 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-perl (1.28-1) unstable; urgency=low * New upstream release. * Make (build) dependency on libhttp-server-simple-perl versioned. * Remove patch cgi.patch, applied upstream. * debian/copyright: update years of upstream copyright.

    2010-04-09 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-perl (1.26-2) unstable; urgency=low * Add patch cgi.patch for compatibility with newer versions of CGI.pm; thanks for Niko Tyni for the bug report and the patch (closes: #577090).

    Advertisement
    Advertisement