libtest-www-mechanize-catalyst-perl_0.59-1_all.deb


Advertisement

Description

libtest-www-mechanize-catalyst-perl - module for automated testing for Catalyst applications

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-www-mechanize-catalyst-perl
Package version: 0.59
Package release: 1
Package architecture: all
Package type: deb
Installed size: 76 B
Download size: 16.84 KB
Official Mirror: ftp.br.debian.org
Test::WWW::Mechanize::Catalyst is a Perl module that combines the well-known Test::WWW::Mechanize module with the power of Catalyst. It allows developers to easily test their Catalyst applications without starting up a web server; in fact, this module works by passing the HTTP request object directly to Catalyst.

    Download

    Source package: libtest-www-mechanize-catalyst-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-www-mechanize-catalyst-perl deb package:
      # sudo apt-get install libtest-www-mechanize-catalyst-perl

    Files

    • /usr/share/doc/libtest-www-mechanize-catalyst-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-www-mechanize-catalyst-perl/changelog.gz
    • /usr/share/doc/libtest-www-mechanize-catalyst-perl/copyright
    • /usr/share/man/man3/Test::WWW::Mechanize::Catalyst.3pm.gz
    • /usr/share/perl5/Test/WWW/Mechanize/Catalyst.pm

    Changelog

    2014-01-15 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-catalyst-perl (0.59-1) unstable; urgency=medium * New upstream release. * Add (build) dependency on libclass-load-perl. * Drop Breaks/Replaces on ancient libcatalyst-modules-perl. * Declare compliance with Debian Policy 3.9.5.

    2013-05-12 - Xavier Guimard <x.guimard@free.fr> libtest-www-mechanize-catalyst-perl (0.58-1) unstable; urgency=low [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Xavier Guimard ] * New upstream version 0.58 * Update dependencies : + libcatalyst-perl >= 5.90000 * Add myself to uploaders * Bump Standards-Version to 3.9.4 * Update debian/copyright (years) [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs

    2012-04-23 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-catalyst-perl (0.57-1) unstable; urgency=low * Add a Pre-Depends on dpkg (>= 1.15.6~) for the xz compression. * New upstream release. * debian/copyright: update to Copyright-Format 1.0. * Bump Standards-Version to 3.9.3 (no changes).

    2011-10-18 - Ansgar Burchardt <ansgar@debian.org> libtest-www-mechanize-catalyst-perl (0.56-1) unstable; urgency=low * Team upload. * New upstream release. * Use XZ compression for source and binary packages.

    2011-09-30 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-catalyst-perl (0.55-1) unstable; urgency=low * New upstream release. * Bump debhelper compatibility level to 8.

    2011-08-10 - Ansgar Burchardt <ansgar@debian.org> libtest-www-mechanize-catalyst-perl (0.54-1) unstable; urgency=low * Team upload. [ Ansgar Burchardt ] * New upstream release. * debian/copyright: Update years of copyright for inc/Module/*. * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * debian/copyright: Replace DEP5 Format-Specification URL from svn.debian.org to anonscm.debian.org URL.

    2011-02-27 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-catalyst-perl (0.53-2) unstable; urgency=low * Add build dependency on libtest-exception-perl (closes: #615500).

    2010-12-16 - Ansgar Burchardt <ansgar@debian.org> libtest-www-mechanize-catalyst-perl (0.53-1) unstable; urgency=low * Team upload. [ gregor herrmann ] * Set Standards-Version to 3.9.1; replace Conflicts with Breaks. [ Ansgar Burchardt ] * New upstream release. * debian/copyright: Refer to /usr/share/common-licenses/GPL-1; refer to "Debian systems" instead of "Debian GNU/Linux systems". * Use source format 3.0 (quilt).

    2010-03-13 - Jonathan Yu <jawnsy@cpan.org> libtest-www-mechanize-catalyst-perl (0.52-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Standards-Version 3.8.4 (no changes) * Use new short debhelper rules format * Rewrite control description * Now depend on WWW::Mechanize 1.54 per upstream * Add myself to Uploaders and Copyright * Refresh copyright to new DEP5 format [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ gregor herrmann ] * Update years of upstream copyright.

    2009-04-16 - gregor herrmann <gregoa@debian.org> libtest-www-mechanize-catalyst-perl (0.51-2) unstable; urgency=low * debian/control: - make the Conflicts: on libcatalyst-modules-perl versioned and add a Replaces:, so that Test::WWW::Mechanize::Catalyst can "move" to this new package - add /me to Uploaders - add build dependencies on libcatalyst-modules-perl (required for tests) and libtest-pod-perl (enabled an additional test) * Don't install README anymore (text version of the POD). * debian/copyright: mention the copyright holder as specified in the source. * debian/rules: unset http_proxy.

    Advertisement
    Advertisement