libtest-useallmodules-perl_0.15-1_all.deb


Advertisement

Description

libtest-useallmodules-perl - test module to do use_ok() for all the MANIFESTed modules

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-useallmodules-perl
Package version: 0.15
Package release: 1
Package architecture: all
Package type: deb
Installed size: 50 B
Download size: 8.23 KB
Official Mirror: ftp.br.debian.org
Test:UseAllModules reads MANIFEST to find modules to be tested and does use_ok() for each of them. Now all you have to do is update MANIFEST. You don't have to modify the test any more (hopefully).

Alternatives

Requires

    Download

    Source package: libtest-useallmodules-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-useallmodules-perl deb package:
      # sudo apt-get install libtest-useallmodules-perl

    Files

    • /usr/share/doc/libtest-useallmodules-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-useallmodules-perl/changelog.gz
    • /usr/share/doc/libtest-useallmodules-perl/copyright
    • /usr/share/man/man3/Test::UseAllModules.3pm.gz
    • /usr/share/perl5/Test/UseAllModules.pm

    Changelog

    2014-07-20 - gregor herrmann <gregoa@debian.org> libtest-useallmodules-perl (0.15-1) unstable; urgency=low * Team upload. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Strip trailing slash from metacpan URLs. * New upstream release. * Don't run release tests during build anymore. * Add build dependency on libextutils-makemaker-cpanfile-perl. * Declare compliance with Debian Policy 3.9.5.

    2012-08-26 - Florian Schlichting <fschlich@zedat.fu-berlin.de> libtest-useallmodules-perl (0.14-1) unstable; urgency=low [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ Ryan Niebur ] * Email change: Ryan Niebur -> ryan@debian.org [ Jonathan Yu ] * New upstream release. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Florian Schlichting ] * Imported Upstream version 0.14. * Bumped Standards-Version to 3.9.3 (use copyright-format 1.0). * Bumped dh compatibility to level 8 (no changes necessary). * Switched to source format 3.0 (quilt). * Switched to short-form debian/rules. * Added myself to uploaders and copyright.

    2009-05-27 - Ryan Niebur <ryanryan52@gmail.com> libtest-useallmodules-perl (0.12-1) unstable; urgency=low * New upstream release

    2009-05-08 - Ryan Niebur <ryanryan52@gmail.com> libtest-useallmodules-perl (0.11-1) unstable; urgency=low * New upstream release

    2009-04-30 - Ryan Niebur <ryanryan52@gmail.com> libtest-useallmodules-perl (0.10-1) unstable; urgency=low * Initial Release. (Closes: #526247)

    Advertisement
    Advertisement