libtest-requiresinternet-perl_0.03-1_all.deb


Advertisement

Description

libtest-requiresinternet-perl - module to easily test network connectivity

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libtest-requiresinternet-perl
Package version 0.03
Package release 1
Package architecture all
Package type deb
Installed size 48 B
Download size 6.38 KB
Official Mirror ftp.br.debian.org
Test::RequiresInternet is intended to easily test network connectivity
before functional tests begin to non-local Internet resources. It does not
require any modules beyond those supplied in core Perl.
If the environment variable NO_NETWORK_TESTING is set, then the tests will be
skipped without attempting any socket connections.
If the sockets cannot connect to the specified hosts and ports, the exception
is caught, reported and the tests skipped.

Alternatives

Package Version Architecture Repository
libtest-requiresinternet-perl_0.03-1_all.deb 0.03 all Debian Main
libtest-requiresinternet-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libtest-requiresinternet-perl_0.03-1_all.deb
Source Package libtest-requiresinternet-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtest-requiresinternet-perl deb package:
    # sudo apt-get install libtest-requiresinternet-perl

Files

Path
/usr/share/doc/libtest-requiresinternet-perl/changelog.Debian.gz
/usr/share/doc/libtest-requiresinternet-perl/changelog.gz
/usr/share/doc/libtest-requiresinternet-perl/copyright
/usr/share/man/man3/Test::RequiresInternet.3pm.gz
/usr/share/perl5/Test/RequiresInternet.pm

Changelog

2014-09-08 - gregor herrmann <gregoa@debian.org>
libtest-requiresinternet-perl (0.03-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Imported upstream version 0.03
* Add autopkgtest control file.
2014-07-03 - gregor herrmann <gregoa@debian.org>
libtest-requiresinternet-perl (0.02-1) unstable; urgency=low
* Initial release (closes: #753639).

See Also

Package Description
libtest-roo-perl_1.004-1_all.deb module for composable, reusable tests with roles and Moo
libtest-routine-perl_0.020-1_all.deb Perl test framework for tests as composable units of assertion
libtest-script-perl_1.07-2_all.deb Perl test module for scripts
libtest-script-run-perl_0.08-1_all.deb Perl module for testing scripts as subprocesses
libtest-sharedfork-perl_0.29-1_all.deb module to run tests in multiple processes and merge results
libtest-signature-perl_1.10-1+deb8u1_all.deb Perl module that provides automatic SIGNATURE testing
libtest-simple-perl_1.001008-1_all.deb set of basic utilities for writing tests in Perl
libtest-spec-perl_0.47-1_all.deb Perl module to write tests in a declarative specification style
libtest-spelling-perl_0.20-1_all.deb Perl module for spellchecking pod formatted text
libtest-strict-perl_0.25-1_all.deb test module for checking the syntax of use strict and test coverage
libtest-subcalls-perl_1.09-2_all.deb Perl module to count subroutine calls
libtest-synopsis-perl_0.11-2_all.deb Perl module to test SYNOPSIS code in PODs
libtest-tabledriven-perl_0.02-1_all.deb write tests, not scripts that run them
libtest-tabs-perl_0.005-1_all.deb check the presence of tabs in your project
libtest-taint-perl_1.06-1+b2_amd64.deb Module to test taintedness
Advertisement
Advertisement