libtest-requires-perl_0.08-1_all.deb


Advertisement

Description

libtest-requires-perl - utility module for tests to check whether modules are available

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-requires-perl
Package version: 0.08
Package release: 1
Package architecture: all
Package type: deb
Installed size: 49 B
Download size: 7.02 KB
Official Mirror: ftp.br.debian.org
Test::Requires is a Perl module for tests written using Test::Builder that simply checks to see if the module can be loaded. If loading the module fails then this skips all tests in the file, rather than causing a complete failure in module testing.

Alternatives

Requires

    Download

    Source package: libtest-requires-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-requires-perl deb package:
      # sudo apt-get install libtest-requires-perl

    Files

    • /usr/share/doc/libtest-requires-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-requires-perl/changelog.gz
    • /usr/share/doc/libtest-requires-perl/copyright
    • /usr/share/man/man3/Test::Requires.3pm.gz
    • /usr/share/perl5/Test/Requires.pm

    Changelog

    2014-07-20 - gregor herrmann <gregoa@debian.org> libtest-requires-perl (0.08-1) unstable; urgency=medium * Team upload. * New upstream release. * Strip trailing slash from metacpan URLs. * debian/copyright: - Drop copyright/license about removed inc/Module/*. - Update upstream copyright notice. - Update years of packaging copyright. * Declare compliance with Debian Policy 3.9.5.

    2013-07-12 - Angel Abad <angel@debian.org> libtest-requires-perl (0.07-1) unstable; urgency=low * Imported Upstream version 0.07. * debian/copyright: - Update Debian paragraph. - Update debian/* section.

    2013-05-05 - gregor herrmann <gregoa@debian.org> libtest-requires-perl (0.06-1) unstable; urgency=low * Team upload. [ Angel Abad ] * New upstream release * Email change: Angel Abad -> angel@debian.org [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Nathan Handler ] * Email change: Nathan Handler -> nhandler@debian.org [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * debian/copyright: switch formatting to Copyright-Format 1.0. * Set Standards-Version to 3.9.4 (no changes). * Bump debhelper compatibility level to 8.

    2010-09-17 - Angel Abad <angelabad@gmail.com> libtest-requires-perl (0.05-1) unstable; urgency=low [ Nathan Handler ] * New upstream release * Switch to dpkg-source 3.0 (quilt) format * debian/control: - Add myself to list of Uploaders - Bump Standards-Version to 3.8.4 (no changes) * debian/copyright: - Use latest revision of DEP5 - Remove inc/Spiffy.pm stanza - Remove inc/test/* stanzas - Add myself to debian/* stanza [ Angel Abad ] * debian/control: Add myself to Uploaders * debian/copyright: Update license information * Bump Standards-Version to 3.9.1 (no changes)

    2010-01-15 - Jonathan Yu <jawnsy@cpan.org> libtest-requires-perl (0.03-1) unstable; urgency=low * Initial Release (Closes: #564615)

    Advertisement
    Advertisement