libtest-prereq-perl_1.038-1_all.deb


Advertisement

Description

libtest-prereq-perl - Perl module to check if Makefile.PL has the right pre-requisites

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-prereq-perl
Package version: 1.038
Package release: 1
Package architecture: all
Package type: deb
Installed size: 67 B
Download size: 15.22 KB
Official Mirror: ftp.br.debian.org
Test::Prerq examines the modules looking on blib/lib/, blib/script, and the test files t/* (and test.pl). then figures out which modules they use, skips the modules that are in the Perl core, and compares the remaining list of modules to those in the PREREQ_PM section of Makefile.PL.

Alternatives

    Download

    Source package: libtest-prereq-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-prereq-perl deb package:
      # sudo apt-get install libtest-prereq-perl

    Files

    • /usr/share/doc/libtest-prereq-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-prereq-perl/changelog.gz
    • /usr/share/doc/libtest-prereq-perl/copyright
    • /usr/share/man/man3/Test::Prereq.3pm.gz
    • /usr/share/man/man3/Test::Prereq::Build.3pm.gz
    • /usr/share/perl5/Test/Prereq.pm
    • /usr/share/perl5/Test/Prereq/Build.pm

    Changelog

    2014-01-10 - gregor herrmann <gregoa@debian.org> libtest-prereq-perl (1.038-1) unstable; urgency=low [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ Ryan Niebur ] + Email change: Ryan Niebur -> ryan@debian.org [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg- copyright" [ gregor herrmann ] * New upstream release. * Switch to "3.0 (quilt)" source format. * Use dh(1), debhelper 8, and drop quilt framework. * Refresh no_cpan_shell.patch (offset). * Update license stanzas in debian/copyright. * Declare compliance with Debian Policy 3.9.5.

    2009-06-26 - gregor herrmann <gregoa@debian.org> libtest-prereq-perl (1.037-1) unstable; urgency=low [ Ryan Niebur ] * New upstream release * Add myself to Uploaders * Debian Policy 3.8.1 * refresh patch * make the short description pass the '$package is a $description' test [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ gregor herrmann ] * Set Standards-Version to 3.8.2 (no changes). * Add /me to Uploaders. * Don't install tests and README as examples.

    2009-02-11 - Rene Mayorga <rmayorga@debian.org> libtest-prereq-perl (1.036-1) unstable; urgency=low * Initial Release. (Closes: #514941)

    Advertisement
    Advertisement