libtest-pod-coverage-perl_1.10-1_all.deb


Advertisement

Description

libtest-pod-coverage-perl - module to check for pod coverage in a distribution

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-pod-coverage-perl
Package version: 1.10
Package release: 1
Package architecture: all
Package type: deb
Installed size: 70 B
Download size: 14.85 KB
Official Mirror: ftp.br.debian.org
Test::Pod::Coverage is a wrapper for Pod::Coverage that automates the process of testing one's documentation for completeness. It is mostly used as a final check before distributing a new release. Also see libpod-coverage-perl.

Alternatives

    Download

    Source package: libtest-pod-coverage-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-pod-coverage-perl deb package:
      # sudo apt-get install libtest-pod-coverage-perl

    Files

    • /usr/share/doc/libtest-pod-coverage-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-pod-coverage-perl/changelog.gz
    • /usr/share/doc/libtest-pod-coverage-perl/copyright
    • /usr/share/man/man3/Test::Pod::Coverage.3pm.gz
    • /usr/share/perl5/Test/Pod/Coverage.pm

    Changelog

    2014-07-20 - gregor herrmann <gregoa@debian.org> libtest-pod-coverage-perl (1.10-1) unstable; urgency=medium * New upstream release. * Strip trailing slash from metacpan URLs. * debian/copyright: switch formatting to Copyright-Format 1.0, update upstream license, bump years of packaging copyright. * Drop unversioned 'perl' from Depends. * Make short description a lowercased noun phrase. * Declare compliance with Debian Policy 3.9.5.

    2013-09-12 - Axel Beckert <abe@debian.org> libtest-pod-coverage-perl (1.08-4) unstable; urgency=low * Team upload [ gregor herrmann ] * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ gregor herrmann ] * Change my email address. [ Chris Butler ] * Fixed a typo in the reference to libpod-coverage-perl in the package description. Closes: #721536 [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * Switch to source format "3.0 (quilt)". * Bump debhelper compatibility to 9 + Update versioned debhelper build-dependency accordingly * Fixes the following lintian-warnings: + dh-clean-k-is-deprecated + debian-rules-missing-recommended-target + copyright-refers-to-symlink-license * Revamp debian/rules: + Use dh_auto_{configure,build,test,install,clean} + Remove now obsolete variable definitions + Remove no more needed parameters to dh_clean and dh_installchangelogs + Remove no more needed manual export of PERL_MM_USE_DEFAULT=1 + Remove ancient and obsolote source and diff targets + Finally switch to a minimal dh7 style debian/rules file * Bump Standards-Version to 3.9.4 (no changes)

    2008-02-27 - gregor herrmann <gregor+debian@comodo.priv.at> libtest-pod-coverage-perl (1.08-3) unstable; urgency=low [ Stephen Gran ] * Lower debhelper compatibility level back to 5 [ gregor herrmann ] * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). Removed: XS- Vcs-Svn fields. * debian/rules: delete /usr/lib/perl5 only if it exists (closes: #467773). * debian/watch: use dist-based URL. * Set Standards-Version to 3.7.3 (no changes). * Set debhelper compatibility level to 6. * Update debian/rules with the help of dh-make-perl. * debian/copyright: update, add upstream source location, switch to new format. * Add /me to Uploaders. [ Joachim Breitner ] * Removed myself from uploaders.

    2006-03-09 - Krzysztof Krzyzaniak (eloy) <eloy@debian.org> libtest-pod-coverage-perl (1.08-2) unstable; urgency=low * debian/control: - libtest-builder-tester-perl replaced by libtest-simple-perl (closes: #356056) - Uploaders: added me

    2006-02-02 - Niko Tyni <ntyni@iki.fi> libtest-pod-coverage-perl (1.08-1) unstable; urgency=low * New upstream release * Add myself to Uploaders. * Upgrade to Standards-Version 3.6.2. No changes needed. * Upgrade to debhelper compatibility level 5. * Move debhelper from Build-Depends-Indep to Build-Depends, as per policy. * Don't ignore the return value of 'make clean'. * Fix a typo in the Recommends field in debian/control.

    2005-04-12 - Gunnar Wolf <gwolf@debian.org> libtest-pod-coverage-perl (1.06-2) unstable; urgency=low * Added debian/watch

    2005-03-10 - Allard Hoeve <allard@byte.nl> libtest-pod-coverage-perl (1.06-1) unstable; urgency=low * Initial Release.

    Advertisement
    Advertisement