libtest-perl-critic-perl_1.02-1_all.deb


Advertisement

Description

libtest-perl-critic-perl - module to use Perl::Critic in test scripts

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-perl-critic-perl
Package version: 1.02
Package release: 1
Package architecture: all
Package type: deb
Installed size: 80 B
Download size: 16.21 KB
Official Mirror: ftp.br.debian.org
Test::Perl::Critic wraps the Perl::Critic engine in a convenient subroutine suitable for test programs written using the Test::More framework. This makes it easy to integrate coding-standards enforcement into the build process. For ultimate convenience (at the expense of some flexibility), see the criticism pragma. If you'd like to try Perl::Critic without installing anything, there is a web service available at http://perlcritic.com. The web service does not support all the configuration features that are available in the native Perl::Critic API, but it should give you a good idea of what it does.

Alternatives

    Download

    Source package: libtest-perl-critic-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-perl-critic-perl deb package:
      # sudo apt-get install libtest-perl-critic-perl

    Files

    • /usr/share/doc/libtest-perl-critic-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-perl-critic-perl/changelog.gz
    • /usr/share/doc/libtest-perl-critic-perl/copyright
    • /usr/share/man/man3/Test::Perl::Critic.3pm.gz
    • /usr/share/perl5/Test/Perl/Critic.pm

    Changelog

    2009-10-23 - Jonathan Yu <jawnsy@cpan.org> libtest-perl-critic-perl (1.02-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Added myself to Uploaders * Standards-Version 3.8.3 (no changes) * Rewrote control description * Bump perlcritic version dep per upstream * Use new short debhelper rules format * Update copyright info from changelog trailers [ gregor herrmann ] * debian/control: Changed: (build-)depend on perl instead of perl- modules. * debian/copyright: update upstream copyright notice.

    2009-01-07 - gregor herrmann <gregoa@debian.org> libtest-perl-critic-perl (1.01-2) unstable; urgency=low [ David Paleino ] * Removed myself from Uploaders (Closes: #509505) * debian/control: - Standards-Version 3.8.0 (no changes needed) - libperl-critic-perl dependency moved to Build-Depends-Indep * debian/copyright: using "Copyright" word for Debian packaging [ gregor herrmann ] * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). * Set debhelper compatibility level to 7; adapt debian/{control,compat,rules}. * debian/copyright: switch to new format. * Add perl-modules (>= 5.10) as an alternative build dependency to libmodule-build-perl. * Add libtest-pod-perl, libtest-pod-coverage-perl to Build-Depends-Indep to activate additional tests. * Add /me to Uploaders.

    2007-12-16 - David Paleino <d.paleino@gmail.com> libtest-perl-critic-perl (1.01-1) unstable; urgency=low * Initial Release.

    Advertisement
    Advertisement