libtest-notabs-perl_1.3-1_all.deb


Advertisement

Description

libtest-notabs-perl - module for scanning for hard tabs in files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libtest-notabs-perl
Package version 1.3
Package release 1
Package architecture all
Package type deb
Installed size 52 B
Download size 9.27 KB
Official Mirror ftp.br.debian.org
Test::NoTabs is a Perl test module that scans your project/distribution for
any Perl files (scripts, modules, etc) that contain hard tabs (the \t, or
0x09) character. Tabs can render with slightly different width depending on
the author's environment, so it's best to use spaces instead.

Alternatives

Package Version Architecture Repository
libtest-notabs-perl_1.3-1_all.deb 1.3 all Debian Main
libtest-notabs-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libtest-notabs-perl_1.3-1_all.deb
Source Package libtest-notabs-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtest-notabs-perl deb package:
    # sudo apt-get install libtest-notabs-perl

Files

Path
/usr/share/doc/libtest-notabs-perl/changelog.Debian.gz
/usr/share/doc/libtest-notabs-perl/changelog.gz
/usr/share/doc/libtest-notabs-perl/copyright
/usr/share/man/man3/Test::NoTabs.3pm.gz
/usr/share/perl5/Test/NoTabs.pm

Changelog

2012-06-27 - gregor herrmann <gregoa@debian.org>
libtest-notabs-perl (1.3-1) unstable; urgency=low
* Team upload.
* New upstream release.
2012-06-16 - gregor herrmann <gregoa@debian.org>
libtest-notabs-perl (1.2-1) unstable; urgency=low
* Team upload.
[ Nicholas Bamber ]
* Added myself to Uploaders
* New upstream release 1.1
* Raised standards version to 3.9.2
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* New upstream release 1.2.
* debian/copyright: update to Copyright-Format 1.0.
* Update years of copyright for inc/*, refresh license stanzas.
* Bump Standards-Version to 3.9.3 (no changes).
* Set debhelper compatibility level to 8.
2010-05-06 - Jonathan Yu <jawnsy@cpan.org>
libtest-notabs-perl (1.0-1) unstable; urgency=low
* Initial Release (Closes: #580533)

See Also

Package Description
libtest-nowarnings-perl_1.04-1_all.deb module to make sure you didn't emit any warnings while testing
libtest-number-delta-perl_1.04-1_all.deb module to compare the difference between numbers against a given tolerance
libtest-object-perl_0.07-2_all.deb Thoroughly testing objects via registered handlers
libtest-output-perl_1.03-1_all.deb perl module to test stdout and stderr messages
libtest-perl-critic-perl_1.02-1_all.deb module to use Perl::Critic in test scripts
libtest-pod-content-perl_0.0.6-1_all.deb Perl module for testing POD content
libtest-pod-coverage-perl_1.10-1_all.deb module to check for pod coverage in a distribution
libtest-pod-no404s-perl_0.01-1_all.deb test utility checking POD for HTTP 404 links
libtest-pod-perl_1.48-1_all.deb module to test for POD errors
libtest-poe-client-tcp-perl_1.12-1_all.deb POE Component providing TCP client services for test cases
libtest-poe-server-tcp-perl_1.14-1_all.deb test framework for TCP client libraries using POE
libtest-portability-files-perl_0.06-1_all.deb Perl module to check that file names in a distribution are portable
libtest-prereq-perl_1.038-1_all.deb Perl module to check if Makefile.PL has the right pre-requisites
libtest-rdf-doap-version-perl_0.010-1_all.deb tests 'meta/changes.ttl' is up to date
libtest-rdf-perl_1.20-1_all.deb Test RDF data for validity and equality
Advertisement
Advertisement