libtest-needsdisplay-perl_1.07-2_all.deb


Advertisement

Description

libtest-needsdisplay-perl - module to ensure that tests needing a display have one

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-needsdisplay-perl
Package version: 1.07
Package release: 2
Package architecture: all
Package type: deb
Installed size: 50 B
Download size: 8.29 KB
Official Mirror: ftp.br.debian.org
When testing GUI applications, sometimes applications or modules absolutely insist on a display, even just to load a module without actually showing any objects. Regardless, this makes GUI applications pretty much impossible to build and test on headless or automated systems. And it fails to the point of not even running the Makefile.PL script because a dependency needs a display so it can be loaded to find a version. In these situations, what is needed is a fake display. The Test::NeedsDisplay module will search around and try to find a way to load some sort of display that can be used for the testing.

Alternatives

Requires

    Download

    Source package: libtest-needsdisplay-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-needsdisplay-perl deb package:
      # sudo apt-get install libtest-needsdisplay-perl

    Files

    • /usr/share/doc/libtest-needsdisplay-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-needsdisplay-perl/changelog.gz
    • /usr/share/doc/libtest-needsdisplay-perl/copyright
    • /usr/share/man/man3/Test::NeedsDisplay.3pm.gz
    • /usr/share/perl5/Test/NeedsDisplay.pm

    Changelog

    2013-06-07 - gregor herrmann <gregoa@debian.org> libtest-needsdisplay-perl (1.07-2) unstable; urgency=low [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. Closes: #711266 [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Switch to "3.0 (quilt)" source format. * debian/copyright: switch formatting to Copyright-Format 1.0. * Bump debhelper compatibility level to 8, use dh(1) in d/rules. * Make short description a noun phrase. * Set Standards-Version to 3.9.4 (no further changes).

    2009-01-05 - gregor herrmann <gregoa@debian.org> libtest-needsdisplay-perl (1.07-1) unstable; urgency=low * New upstream release. * Add /me to Uploaders. * debian/copyright: update years of copyright.

    2008-12-02 - Damyan Ivanov <dmn@debian.org> libtest-needsdisplay-perl (1.05-1) unstable; urgency=low * Initial Release. (Closes: #507548)

    Advertisement
    Advertisement