libtest-most-perl_0.34-1_all.deb


Advertisement

Description

libtest-most-perl - Perl module with the most commonly needed test functions and features

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-most-perl
Package version: 0.34
Package release: 1
Package architecture: all
Package type: deb
Installed size: 86 B
Download size: 25.04 KB
Official Mirror: ftp.br.debian.org
Test::Most provides the most commonly used testing functions and gives a bit more fine-grained control over your test suite. All functions from the following modules will automatically be exported: * Test::More * Test::Exception * Test::Differences * Test::Deep * Test::Warn This is useful when one is used to most of the above modules but wouldn't want to bother to load them all explicitly. Test::Most also provides a couple of routines to control tests behaviour in case of errors.

Alternatives

    Download

    Source package: libtest-most-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-most-perl deb package:
      # sudo apt-get install libtest-most-perl

    Files

    • /usr/share/doc/libtest-most-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-most-perl/changelog.gz
    • /usr/share/doc/libtest-most-perl/copyright
    • /usr/share/man/man3/Test::Most.3pm.gz
    • /usr/share/man/man3/Test::Most::Exception.3pm.gz
    • /usr/share/perl5/Test/Most.pm
    • /usr/share/perl5/Test/Most/Exception.pm

    Changelog

    2014-08-03 - gregor herrmann <gregoa@debian.org> libtest-most-perl (0.34-1) unstable; urgency=medium * Team upload. * New upstream release. * Strip trailing slash from metacpan URLs.

    2014-01-12 - Florian Schlichting <fsfs@debian.org> libtest-most-perl (0.33-1) unstable; urgency=low [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Florian Schlichting ] * Import Upstream version 0.33 * Add upstream-repo URL to Source field * Email change: Florian Schlichting -> fsfs@debian.org * Add myself to d/copyright * Drop build-dependency on Module::Build, obsoleted by switch to Makefile.PL * Declare compliance with Debian Policy 3.9.5

    2012-10-04 - Florian Schlichting <fschlich@zedat.fu-berlin.de> libtest-most-perl (0.31-1) unstable; urgency=low [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Florian Schlichting ] * Imported Upstream version 0.31. * Bumped Standards-Version to 3.9.4 (no change). * Bumped build-dependency on Module::Build to 0.4. * Added myself to Uploaders.

    2012-05-27 - Salvatore Bonaccorso <carnil@debian.org> libtest-most-perl (0.25-1) unstable; urgency=low * Team upload [ Ansgar Burchardt ] * Email change: Ansgar Burchardt -> ansgar@debian.org * debian/control: Convert Vcs-* fields to Git. [ Maximilian Gass ] * New upstream release 0.24 * Update versions on dependencies [ Fabrizio Regalli ] * New upstream release 0.25 [ Salvatore Bonaccorso ] * Email change: Salvatore Bonaccorso -> carnil@debian.org * Update (build-)dependencies in debian/control file. Update Build-Depends-Indep on libmodule-build-perl to be an alternative build dependency with perl (>= 5.11.3). Add alternative (Build-)Depends(-Indep) on libtest-harness-perl with perl (>= 5.13.3). Make versioned (Build-)Depends(-Indep) on libtest-deep-perl unversioned as the required dependency is satisfied already in squeeze. Drop alternative (Build-)Depends(-Indep) for Test::Simple 0.88, which is already present in squeeze. * Update copyright file information. Update format to copyright-format 1.0 as released together with Debian policy 3.9.3. Update copyright years for debian/* packaging. * Bump Standards-Version to 3.9.3

    2010-09-13 - Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com> libtest-most-perl (0.23-1) unstable; urgency=low * Team upload. * New upstream release * debian/copyright: Refer to Debian systems instead of Debian GNU/Linux systems. * debian/watch: Remove comments from watch file.

    2010-08-09 - Ansgar Burchardt <ansgar@43-1.org> libtest-most-perl (0.22-1) unstable; urgency=low [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ gregor herrmann ] * Add perl (>= 5.10.1) as an alternative (build) dependency for Test::Simple and Test::Harness. [ Ansgar Burchardt ] * New upstream release. * Use tiny rules with debhelper 8. * Remove build-dep on libmodule-build-perl (included in perl since 5.10). * Make (build-)dep on libexception-class-perl, libtest-warn-perl unversioned as the requirement is already satisfied in stable. * Bump (build-)dep on libtest-deep-perl to >= 0.106. * Bump (build-)dep on libtest-differences-perl to >= 0.50. * Bump (build-)dep on libtest-exception-perl to >= 0.29. * Bump (build-)dep on libtest-simple-perl to >= 0.88. * debian/copyright: Formatting changes for current DEP-5 proposal; refer to /usr/share/common-licenses/GPL-1. * Bump Standards-Version to 3.9.1. * Add myself to Uploaders.

    2009-03-31 - Damyan Ivanov <dmn@debian.org> libtest-most-perl (0.21-1) unstable; urgency=low * Initial Release. (Closes: #522006 -- ITP)

    Advertisement
    Advertisement