libtest-moose-more-perl_0.024-1_all.deb


Advertisement

Description

libtest-moose-more-perl - collection of tools for testing Moose packages

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libtest-moose-more-perl
Package version 0.024
Package release 1
Package architecture all
Package type deb
Installed size 69 B
Download size 12.84 KB
Official Mirror ftp.br.debian.org
Test::Moose::More contains a number of additional tests that can be employed
against Moose classes/roles. It is intended to replace Test::Moose in tests.

Alternatives

Package Version Architecture Repository
libtest-moose-more-perl_0.024-1_all.deb 0.024 all Debian Main
libtest-moose-more-perl - - -

Requires

Name Value
libdata-optlist-perl -
libmoose-autobox-perl -
libmoose-perl -
libsub-exporter-perl -
libsyntax-keyword-junction-perl -
libtest-simple-perl >= 0.94
perl >= 5.11.1
perl -

Download

Type URL
Binary Package libtest-moose-more-perl_0.024-1_all.deb
Source Package libtest-moose-more-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtest-moose-more-perl deb package:
    # sudo apt-get install libtest-moose-more-perl

Files

Path
/usr/share/doc/libtest-moose-more-perl/changelog.Debian.gz
/usr/share/doc/libtest-moose-more-perl/changelog.gz
/usr/share/doc/libtest-moose-more-perl/copyright
/usr/share/man/man3/Test::Moose::More.3pm.gz
/usr/share/perl5/Test/Moose/More.pm

Changelog

2014-05-16 - gregor herrmann <gregoa@debian.org>
libtest-moose-more-perl (0.024-1) unstable; urgency=medium
* New upstream release.
2014-03-01 - gregor herrmann <gregoa@debian.org>
libtest-moose-more-perl (0.023-1) unstable; urgency=medium
* New upstream release.
* Update years of packaging copyright.
2013-12-22 - gregor herrmann <gregoa@debian.org>
libtest-moose-more-perl (0.022-1) unstable; urgency=low
* Initial release (closes: #732811).

See Also

Package Description
libtest-most-perl_0.34-1_all.deb Perl module with the most commonly needed test functions and features
libtest-needsdisplay-perl_1.07-2_all.deb module to ensure that tests needing a display have one
libtest-net-ldap-perl_0.04-1_all.deb Net::LDAP subclass for testing
libtest-nobreakpoints-perl_0.15-1_all.deb module to test that files do not contain soft breakpoints
libtest-notabs-perl_1.3-1_all.deb module for scanning for hard tabs in files
libtest-nowarnings-perl_1.04-1_all.deb module to make sure you didn't emit any warnings while testing
libtest-number-delta-perl_1.04-1_all.deb module to compare the difference between numbers against a given tolerance
libtest-object-perl_0.07-2_all.deb Thoroughly testing objects via registered handlers
libtest-output-perl_1.03-1_all.deb perl module to test stdout and stderr messages
libtest-perl-critic-perl_1.02-1_all.deb module to use Perl::Critic in test scripts
libtest-pod-content-perl_0.0.6-1_all.deb Perl module for testing POD content
libtest-pod-coverage-perl_1.10-1_all.deb module to check for pod coverage in a distribution
libtest-pod-no404s-perl_0.01-1_all.deb test utility checking POD for HTTP 404 links
libtest-pod-perl_1.48-1_all.deb module to test for POD errors
libtest-poe-client-tcp-perl_1.12-1_all.deb POE Component providing TCP client services for test cases
Advertisement
Advertisement