libtest-module-used-perl_0.2.4-1_all.deb


Advertisement

Description

libtest-module-used-perl - module for testing whether a module is used

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-module-used-perl
Package version: 0.2.4
Package release: 1
Package architecture: all
Package type: deb
Installed size: 68 B
Download size: 11.59 KB
Official Mirror: ftp.br.debian.org
Test::Module::Used is a Perl test module for determining whether a module is really used (and vice versa) between lib/t and META.yml. It is useful for detecting cases where dependencies are specified (possibly as a remnant of older versions) but no longer needed, or where one forgets to declare them.

Alternatives

    Download

    Source package: libtest-module-used-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-module-used-perl deb package:
      # sudo apt-get install libtest-module-used-perl

    Files

    • /usr/share/doc/libtest-module-used-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-module-used-perl/changelog.gz
    • /usr/share/doc/libtest-module-used-perl/copyright
    • /usr/share/man/man3/Test::Module::Used.3pm.gz
    • /usr/share/perl5/Test/Module/Used.pm

    Changelog

    2013-06-07 - gregor herrmann <gregoa@debian.org> libtest-module-used-perl (0.2.4-1) unstable; urgency=low * Team upload. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. Fixes "FTBFS with perl 5.18: test failures" (Closes: #711264) * debian/copyright: switch formatting to Copyright-Format 1.0. * Update years of upstream copyright. * Bump debhelper compatibility level to 8. * Set Standards-Version to 3.9.4 (no further changes).

    2011-05-19 - Salvatore Bonaccorso <carnil@debian.org> libtest-module-used-perl (0.2.3-1) unstable; urgency=low * Team upload. [ Nicholas Bamber ] * New upstream release (Closes: #627233) [ Salvatore Bonaccorso ] * Bump Standards-Version to 3.9.2.

    2011-01-17 - Nicholas Bamber <nicholas@periapt.co.uk> libtest-module-used-perl (0.2.2-1) unstable; urgency=low [ Ansgar Burchardt ] * Update my email address. [ Nicholas Bamber ] * Added myself to Uploaders * New upstream release * Upped standards version to 3.9.1 * Refreshed copyright * Updated dependencies

    2010-05-24 - Ansgar Burchardt <ansgar@43-1.org> libtest-module-used-perl (0.2.0-1) unstable; urgency=low [ Ansgar Burchardt ] * New upstream release. * debian/copyright: Update years of copyright for inc/*. * Use source format 3.0 (quilt). * Add myself to Uploaders. [ gregor herrmann ] * Improve short description.

    2010-02-02 - Jonathan Yu <jawnsy@cpan.org> libtest-module-used-perl (0.1.9-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Standards-Version 3.8.4 (no changes) [ gregor herrmann ] * Update years of upstream copyright.

    2010-01-05 - Jonathan Yu <jawnsy@cpan.org> libtest-module-used-perl (0.1.7-1) unstable; urgency=low * Initial Release (Closes: #563459)

    Advertisement
    Advertisement