libtest-distmanifest-perl_1.009-1_all.deb


Advertisement

Description

libtest-distmanifest-perl - Perl module for verifying CPAN MANIFEST files

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-distmanifest-perl
Package version: 1.009
Package release: 1
Package architecture: all
Package type: deb
Installed size: 84 B
Download size: 17.52 KB
Official Mirror: ftp.br.debian.org
Test::DistManifest provides a simple method of testing that a MANIFEST matches the distribution. It is similar to Test::CheckManifest, but differs in that it has native support for the MANIFEST.SKIP file. It tests three things: 1. Everything in MANIFEST exists 2. Everything in the package is listed in MANIFEST, or subsequently matches a regular expression mask in MANIFEST.SKIP 3. Nothing exists in MANIFEST that also matches a mask in MANIFEST.SKIP, which is an unsatisfiable condition Much of the functionality is provided by Module::Manifest, so developers wishing to manipulate MANIFEST files in a similar way are encouraged to look at that distribution.

Alternatives

    Download

    Source package: libtest-distmanifest-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-distmanifest-perl deb package:
      # sudo apt-get install libtest-distmanifest-perl

    Files

    • /usr/share/doc/libtest-distmanifest-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-distmanifest-perl/changelog.gz
    • /usr/share/doc/libtest-distmanifest-perl/copyright
    • /usr/share/doc/libtest-distmanifest-perl/examples/checkmanifest.t
    • /usr/share/man/man3/Test::DistManifest.3pm.gz
    • /usr/share/perl5/Test/DistManifest.pm

    Changelog

    2009-12-28 - Jonathan Yu <jawnsy@cpan.org> libtest-distmanifest-perl (1.009-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release [ gregor herrmann ] * debian/control: Changed: (build-)depend on perl instead of perl- modules.

    2009-10-13 - Jonathan Yu <jawnsy@cpan.org> libtest-distmanifest-perl (1.005-1) unstable; urgency=low * New upstream release

    2009-09-30 - Jonathan Yu <jawnsy@cpan.org> libtest-distmanifest-perl (1.003-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release + Remove Perl::Critic tests (Closes: #538115) * Standards-Version 3.8.3 (no changes) * Bump to short debhelper rules version * Enable Test::Kwalitee tests (add to B-D-I) [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ Ryan Niebur ] * Update jawnsy's email address

    2009-05-15 - Jonathan Yu <frequency@cpan.org> libtest-distmanifest-perl (1.2.2-1) unstable; urgency=low * New upstream release * Added non-fatal errors; that is, tests that warn but do not fail. This is useful for Debian distributions. * Fixed dependency order (perl-modules before the dual life module) * Used 1-space for continued B-D, B-D-I, Depends, etc.

    2009-04-28 - Jonathan Yu <frequency@cpan.org> libtest-distmanifest-perl (1.1.4-1) unstable; urgency=low * Initial Release. (Closes: #519657)

    Advertisement
    Advertisement