libtest-consistentversion-perl_0.2.3-1_all.deb


Advertisement

Description

libtest-consistentversion-perl - module to ensure consistent versions in a package

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libtest-consistentversion-perl
Package version 0.2.3
Package release 1
Package architecture all
Package type deb
Installed size 64 B
Download size 8.94 KB
Official Mirror ftp.br.debian.org
Test::ConsistentVersion is a Perl module that ensures consistent versioning
in all modules of a package. It also checks that the README and Changes files
match the module version.

Alternatives

Package Version Architecture Repository
libtest-consistentversion-perl_0.2.3-1_all.deb 0.2.3 all Debian Main
libtest-consistentversion-perl - - -

Requires

Name Value
libautodie-perl -
libtest-pod-content-perl -
libtest-simple-perl >= 0.94
perl >= 5.11.1
perl -
perl >= 5.10.1

Download

Type URL
Binary Package libtest-consistentversion-perl_0.2.3-1_all.deb
Source Package libtest-consistentversion-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtest-consistentversion-perl deb package:
    # sudo apt-get install libtest-consistentversion-perl

Files

Path
/usr/share/doc/libtest-consistentversion-perl/changelog.Debian.gz
/usr/share/doc/libtest-consistentversion-perl/changelog.gz
/usr/share/doc/libtest-consistentversion-perl/copyright
/usr/share/man/man3/Test::ConsistentVersion.3pm.gz
/usr/share/perl5/Test/ConsistentVersion.pm

Changelog

2011-05-12 - Nicholas Bamber <nicholas@periapt.co.uk>
libtest-consistentversion-perl (0.2.3-1) unstable; urgency=low
[ Nicholas Bamber ]
* Added myself to Uploaders
* Upped standards version to 3.9.1
* Refreshed copyright
* New upstream release
* echo '3.0 (quilt)' > debian/source/format
* Reviewed dependencies
* Added Depends clause on libtest-pod-content-perl (Closes: #619073)
[ gregor herrmann ]
* Add perl (>= 5.11.1) as an alternative for Test::More.
* Set Standards-Version to 3.9.2 (no changes).
2010-01-17 - Jonathan Yu <jawnsy@cpan.org>
libtest-consistentversion-perl (0.2.2-1) unstable; urgency=low
* Initial Release (Closes: #565469)

See Also

Package Description
libtest-corpus-audio-mpd-perl_1.120990-1_all.deb module to fake mpd for testing purposes
libtest-cpan-meta-perl_0.23-1_all.deb test module to validate package metadata for CPAN
libtest-cpan-meta-yaml-perl_0.22-1_all.deb test module to validate a META.yml file
libtest-cukes-perl_0.10-1_all.deb test framework inspired by Cucumber
libtest-data-perl_1.24-1_all.deb module to check properties and values of data and variables
libtest-database-perl_1.112-1_all.deb support for testing against multiple unspecified databases
libtest-databaserow-perl_2.04-1_all.deb module for simple database tests
libtest-debian-perl_0.03-1_all.deb perl tests for debian
libtest-deep-perl_0.113-1_all.deb Perl module for extremely flexible deep comparisons
libtest-deep-unorderedpairs-perl_0.003-1_all.deb Test::Deep plugin for comparing lists as if they were hashes
libtest-dependencies-perl_0.12-1_all.deb module to verify dependencies listed in Makefile.PL
libtest-differences-perl_0.62-1_all.deb Perl module to test string and data structure differences
libtest-dir-perl_1.013-1_all.deb module for testing directory attributes
libtest-distmanifest-perl_1.009-1_all.deb Perl module for verifying CPAN MANIFEST files
libtest-distribution-perl_2.00-3_all.deb perform tests on all modules of a distribution
Advertisement
Advertisement