libtest-class-perl_0.47-1_all.deb


Advertisement

Description

libtest-class-perl - module for creating test classes in an xUnit style

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-class-perl
Package version: 0.47
Package release: 1
Package architecture: all
Package type: deb
Installed size: 150 B
Download size: 56.25 KB
Official Mirror: ftp.br.debian.org
Test::Class is a Perl test harness for creating tests using the xUnit style inspired by Smalltalk. It is aimed at authors of Perl modules already using Test::Builder-based modules.

Alternatives

    Download

    Source package: libtest-class-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-class-perl deb package:
      # sudo apt-get install libtest-class-perl

    Files

    • /usr/share/doc/libtest-class-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-class-perl/changelog.gz
    • /usr/share/doc/libtest-class-perl/copyright
    • /usr/share/man/man3/Test::Class.3pm.gz
    • /usr/share/man/man3/Test::Class::Load.3pm.gz
    • /usr/share/man/man3/Test::Class::MethodInfo.3pm.gz
    • /usr/share/perl5/Test/Class.pm
    • /usr/share/perl5/Test/Class/Load.pm
    • /usr/share/perl5/Test/Class/MethodInfo.pm

    Changelog

    2014-09-27 - Salvatore Bonaccorso <carnil@debian.org> libtest-class-perl (0.47-1) unstable; urgency=medium [ Salvatore Bonaccorso ] * Imported Upstream version 0.46 * Update Vcs-Browser URL to cgit web frontend [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Imported Upstream version 0.47 * Declare compliance with Debian Policy 3.9.6

    2014-07-06 - Salvatore Bonaccorso <carnil@debian.org> libtest-class-perl (0.45-1) unstable; urgency=medium * Imported Upstream version 0.45 * Add alternative Build-Depends-Indep for Test::More requirements. Add laternative Build-Depends-Indep on libtest-simple-perl (>= 1.001002) or perl (>= 5.19.6) for the testsuite.

    2014-07-05 - Salvatore Bonaccorso <carnil@debian.org> libtest-class-perl (0.44-1) unstable; urgency=medium * Imported Upstream version 0.44

    2014-06-26 - Salvatore Bonaccorso <carnil@debian.org> libtest-class-perl (0.43-1) unstable; urgency=medium * Imported Upstream version 0.43 * Update versioned Build-Depends for Module::Build. Update alternative Build-Depends for Module::Build to libmodule-build-perl (>= 0.420400) | perl (>= 5.19.8).

    2014-05-09 - Salvatore Bonaccorso <carnil@debian.org> libtest-class-perl (0.42-1) unstable; urgency=medium [ gregor herrmann ] * Strip trailing slash from metacpan URLs. [ Salvatore Bonaccorso ] * Imported Upstream version 0.42 * Update copyright years for debian/* packaging files

    2013-12-14 - Salvatore Bonaccorso <carnil@debian.org> libtest-class-perl (0.41-1) unstable; urgency=medium * Imported Upstream version 0.41 * Bump versioned build dependency for Module::Build. Built requires at least Module::Build 0.42. Update the Build-Depends to an alternative dependency on libmodule-build-perl (>= 0.420200) or perl (>= 5.19.6)

    2013-11-22 - Salvatore Bonaccorso <carnil@debian.org> libtest-class-perl (0.40-1) unstable; urgency=low * Imported Upstream version 0.40 * Bump Standards-Version to 3.9.5

    2013-05-17 - Salvatore Bonaccorso <carnil@debian.org> libtest-class-perl (0.39-1) unstable; urgency=low * Imported Upstream version 0.38 and 0.39 * Bump Standards-Version to 3.9.4 * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs * Update copyright years for debian/* packaging files

    2012-06-27 - gregor herrmann <gregoa@debian.org> libtest-class-perl (0.37-1) unstable; urgency=low [ Salvatore Bonaccorso ] * Email change: Salvatore Bonaccorso -> carnil@debian.org [ Ansgar Burchardt ] * Email change: Ansgar Burchardt -> ansgar@debian.org * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * New upstream release. * debian/copyright: update to Copyright-Format 1.0. * debian/copyright: update years of packaging copyright and license stanzas. * Bump Standards-Version to 3.9.3 (no changes). * Set debhelper compatibility level to 8. * Build-Depend on Module::Build 0.38. * Update versioned (build) dependencies after the lenny archival.

    2010-08-20 - Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com> libtest-class-perl (0.36-1) unstable; urgency=low * New upstream release * Refresh debian/copyright and refer explicitly to GPL-1 license text in common-licenses. * Make versioned (Build-)Depends(-Indep) on libtest-exception-perl unversioned as already satisfied in stable and oldstable is gone. * Bump Standards-Version to 3.9.1.

    Advertisement
    Advertisement