libtest-class-most-perl_0.07-1_all.deb


Advertisement

Description

libtest-class-most-perl - module to reduce boilerplate code when testing classes

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libtest-class-most-perl
Package version 0.07
Package release 1
Package architecture all
Package type deb
Installed size 59 B
Download size 10.71 KB
Official Mirror ftp.br.debian.org
Test::Class::Most acts as a combination of Test::Class, Test::Most and
Modern::Perl, thus saving a lot of typing boilerplate code when writing
tests for Perl classes.

Alternatives

Package Version Architecture Repository
libtest-class-most-perl_0.07-1_all.deb 0.07 all Debian Main
libtest-class-most-perl - - -

Requires

Name Value
libtest-class-perl -
libtest-most-perl >= 0.31
perl -

Download

Type URL
Binary Package libtest-class-most-perl_0.07-1_all.deb
Source Package libtest-class-most-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtest-class-most-perl deb package:
    # sudo apt-get install libtest-class-most-perl

Files

Path
/usr/share/doc/libtest-class-most-perl/changelog.Debian.gz
/usr/share/doc/libtest-class-most-perl/changelog.gz
/usr/share/doc/libtest-class-most-perl/copyright
/usr/share/man/man3/Test::Class::Most.3pm.gz
/usr/share/perl5/Test/Class/Most.pm

Changelog

2012-10-04 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libtest-class-most-perl (0.07-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Florian Schlichting ]
* Imported Upstream version 0.07.
* Bumped Standards-Version to 3.9.4 (use copyright-format 1.0).
* Bumped (build-)dependency on libtest-most-perl to 0.31. "This fixes
prototype warnings when using Moose."
* Bumped build-dependency on Module::Build to 0.4.
2012-01-12 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libtest-class-most-perl (0.06-1) unstable; urgency=low
* Imported Upstream version 0.06.
* Added build-dependency on Module::Build 0.38.
* Improved short description a little.
2011-10-05 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libtest-class-most-perl (0.05-1) unstable; urgency=low
* Initial Release. (Closes: #644331)

See Also

Package Description
libtest-class-perl_0.47-1_all.deb module for creating test classes in an xUnit style
libtest-classapi-perl_1.06-2_all.deb Perl extension for basic first-pass API testing for class trees
libtest-cleannamespaces-perl_0.16-1_all.deb module to check for uncleaned imports
libtest-cmd-perl_1.06-1_all.deb perl module which provides a testing framework
libtest-command-perl_0.11-1_all.deb Perl module for testing external commands
libtest-command-simple-perl_0.04-4_all.deb Perl module to test external commands
libtest-compile-perl_1.2.0-2_all.deb test module for checking that scripts and modules compile
libtest-consistentversion-perl_0.2.3-1_all.deb module to ensure consistent versions in a package
libtest-corpus-audio-mpd-perl_1.120990-1_all.deb module to fake mpd for testing purposes
libtest-cpan-meta-perl_0.23-1_all.deb test module to validate package metadata for CPAN
libtest-cpan-meta-yaml-perl_0.22-1_all.deb test module to validate a META.yml file
libtest-cukes-perl_0.10-1_all.deb test framework inspired by Cucumber
libtest-data-perl_1.24-1_all.deb module to check properties and values of data and variables
libtest-database-perl_1.112-1_all.deb support for testing against multiple unspecified databases
libtest-databaserow-perl_2.04-1_all.deb module for simple database tests
Advertisement
Advertisement