libtest-checkdeps-perl_0.010-1_all.deb


Advertisement

Description

libtest-checkdeps-perl - check for presence of dependencies

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-checkdeps-perl
Package version: 0.010
Package release: 1
Package architecture: all
Package type: deb
Installed size: 53 B
Download size: 10.32 KB
Official Mirror: ftp.br.debian.org
Test::CheckDeps adds a test that assures all dependencies have been installed properly. If requested, it can bail out all testing on error.

Alternatives

    Download

    Source package: libtest-checkdeps-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-checkdeps-perl deb package:
      # sudo apt-get install libtest-checkdeps-perl

    Files

    • /usr/share/doc/libtest-checkdeps-perl/README
    • /usr/share/doc/libtest-checkdeps-perl/buildinfo_all.gz
    • /usr/share/doc/libtest-checkdeps-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-checkdeps-perl/changelog.gz
    • /usr/share/doc/libtest-checkdeps-perl/copyright
    • /usr/share/man/man3/Test::CheckDeps.3pm.gz
    • /usr/share/perl5/Test/CheckDeps.pm

    Changelog

    2013-12-11 - gregor herrmann <gregoa@debian.org> libtest-checkdeps-perl (0.010-1) unstable; urgency=medium * Team upload. * New upstream release. * Make Vcs-Git URL canonical. * Declare compliance with Debian Policy 3.9.5.

    2013-10-01 - intrigeri <intrigeri@debian.org> libtest-checkdeps-perl (0.008-1) unstable; urgency=low * Team upload. [ upstream ] + Switch back to MakeMaker. + Bump prereq on CPAN::Meta::Check to 0.007. [ intrigeri ] * Include perl-makemaker.mk (not perl-build.mk). * Update package relations: + Drop dependency on libmodule-build-tiny-perl. + Version dependency on libcpan-meta-check-perl (>= 0.007). + Allow CPAN::Meta to be provided by perl (>= 5.14).

    2013-07-15 - Jonas Smedegaard <dr@jones.dk> libtest-checkdeps-perl (0.006-1) unstable; urgency=low [ upstream ] * New release. + Require CPAN::Meta::Check 0.004. + Explicitly require CPAN::Meta 2.120920. + Switch to Module::Build::Tiny. [ Jonas Smedegaard ] * Include perl-build.mk (not perl-makemaker.mk). * Update package relations: + Tighten to (build-)depend versioned on libcpan-meta-perl. + Build-depend on libmodule-build-tiny-perl. + Tighten to build-depend versioned on cdbs: Needed for Module::Build::Tiny.

    2013-06-08 - Jonas Smedegaard <dr@jones.dk> libtest-checkdeps-perl (0.004-1) unstable; urgency=low [ upstream ] * New release. + Sort dependencies before displaying them. + check_dependencies() can now optionally also test recommended and suggested prerequisites. + Reinstate loading of CPAN::Meta. [ Salvatore Bonaccorso ] * Use canonical host (anonscm.debian.org) in Vcs-Git URI. [ Jonas Smedegaard ] * Add README.source emphasizing control.in file as *not* a show-stopper for contributions, referring to wiki page for details. * Add git URL as alternate source. * Stop tracking md5sum of upstream tarball. * Remove debian/source/local-options: abort-on-upstream-changes and unapply-patches are default in dpkg-source since 1.16.1. * Bump dephelper compatibility level to 8. * Bump standards-version to 3.9.4. * Fix use comment and license pseudo-sections in copyright file to obey silly restrictions of copyright format 1.0. * Bump packaging license to GPL-3+, and extend copyrigt coverage for myself to include current year. * Relax to build-depend unversioned on cdbs: Needed version satisfied even in oldstable.

    2012-05-09 - Jonas Smedegaard <dr@jones.dk> libtest-checkdeps-perl (0.002-1) unstable; urgency=low * Initial packaging release. Closes: bug#672163.

    Advertisement
    Advertisement