libtest-block-perl_0.13-1_all.deb


Advertisement

Description

libtest-block-perl - module for specifying tests with a finer granularity

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-block-perl
Package version: 0.13
Package release: 1
Package architecture: all
Package type: deb
Installed size: 57 B
Download size: 12.05 KB
Official Mirror: ftp.br.debian.org
Test::Block allows one to specify the number of expected tests at a finer level of granularity than an entire test script. It is built with Test::Builder and plays happily with Test::More and friends. Note: Test::Block has been marked DEPRECATED by its author. It was written before subtests existed in TAP and Test::More. These days subtests will probably be a better option for you.

Alternatives

    Download

    Source package: libtest-block-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-block-perl deb package:
      # sudo apt-get install libtest-block-perl

    Files

    • /usr/share/doc/libtest-block-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-block-perl/changelog.gz
    • /usr/share/doc/libtest-block-perl/copyright
    • /usr/share/man/man3/Test::Block.3pm.gz
    • /usr/share/perl5/Test/Block.pm

    Changelog

    2012-01-28 - Florian Schlichting <fschlich@zedat.fu-berlin.de> libtest-block-perl (0.13-1) unstable; urgency=low [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Florian Schlichting ] * Imported Upstream version 0.13. * Added deprecation warning to long description. * Converted to source format "3.0 (quilt)". * Use minimal debian/rules. * Bumped debhelper compatibility to 8 (no changes). * Bumped Standards-Version to 3.9.2 (no longer depend on versions of Perl satisfied in oldstable). * Refreshed debian/copyright. * Added myself to Uploaders. [ gregor herrmann ] * Build-depend on Module::Build 0.38. * Make short description a noun phrase.

    2008-09-18 - Jeremiah C. Foster <jeremiah@jeremiahfoster.com> libtest-block-perl (0.11-1) unstable; urgency=low * Initial Release, Closes: #494664

    Advertisement
    Advertisement