libtest-assertions-perl_1.054-2_all.deb


Advertisement

Description

libtest-assertions-perl - simple set of building blocks for unit and runtime testing

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtest-assertions-perl
Package version: 1.054
Package release: 2
Package architecture: all
Package type: deb
Installed size: 120 B
Download size: 30.63 KB
Official Mirror: ftp.br.debian.org
Test::Assertions provides a convenient set of tools for constructing tests, such as unit tests or run-time assertion checks (like C's ASSERT macro). Unlike some of the Test:: modules available on CPAN, Test::Assertions is not limited to unit test scripts; for example it can be used to check if output is as expected within a benchmarking script. When it is used for unit tests, it generates output in the standard form for CPAN unit testing (under Test::Harness).

Alternatives

    Download

    Source package: libtest-assertions-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtest-assertions-perl deb package:
      # sudo apt-get install libtest-assertions-perl

    Files

    • /usr/share/doc/libtest-assertions-perl/changelog.Debian.gz
    • /usr/share/doc/libtest-assertions-perl/changelog.gz
    • /usr/share/doc/libtest-assertions-perl/copyright
    • /usr/share/man/man3/Test::Assertions.3pm.gz
    • /usr/share/man/man3/Test::Assertions::Manual.3pm.gz
    • /usr/share/man/man3/Test::Assertions::TestScript.3pm.gz
    • /usr/share/perl5/Test/Assertions.pm
    • /usr/share/perl5/Test/Assertions/Manual.pod
    • /usr/share/perl5/Test/Assertions/TestScript.pm

    Changelog

    2009-01-07 - gregor herrmann <gregoa@debian.org> libtest-assertions-perl (1.054-2) unstable; urgency=low [ David Paleino ] * debian/control: removed myself from Uploaders (Closes: #509508) [ gregor herrmann ] * debian/control: - added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza). Removed: XS-Vcs-Svn fields - added: ${misc:Depends} to Depends: field - set Standards-Version to 3.8.0 (no changes) - add /me to Uploaders * Don't install README anymore. * Set debhelper compatibility level to 7; adapt debian/{control,compat,rules}. * debian/copyright: switch to new format.

    2007-09-18 - David Paleino <d.paleino@gmail.com> libtest-assertions-perl (1.054-1) unstable; urgency=low WAITING FOR liblog-trace-perl * Initial Release.

    Advertisement
    Advertisement