libterm-size-perl_0.207-1+b2_amd64.deb


Advertisement

Description

libterm-size-perl - Perl extension for retrieving terminal size

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libterm-size-perl
Package version: 0.207
Package release: 1+b2
Package architecture: amd64
Package type: deb
Installed size: 20 B
Download size: 11.15 KB
Official Mirror: ftp.br.debian.org
Term::Size is a Perl module which provides a straightforward way to retrieve the terminal size, either as characters or pixels. Optionally, a file handle may be specified to retrieve the width and height of the associated terminal.

Alternatives

    Download

    Source package: libterm-size-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libterm-size-perl deb package:
      # sudo apt-get install libterm-size-perl

    Files

    • /usr/lib/x86_64-linux-gnu/perl5/5.20/Term/Size.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Term/Size/Size.so
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Term/Size/autosplit.ix
    • /usr/share/doc/libterm-size-perl/changelog.Debian.amd64.gz
    • /usr/share/doc/libterm-size-perl/changelog.Debian.gz
    • /usr/share/doc/libterm-size-perl/changelog.gz
    • /usr/share/doc/libterm-size-perl/copyright
    • /usr/share/man/man3/Term::Size.3pm.gz

    Changelog

    2012-03-04 - Florian Schlichting <fschlich@zedat.fu-berlin.de> libterm-size-perl (0.207-1) unstable; urgency=low [ Damyan Ivanov ] * New upstream release * watch: mangle upstream versions to always force three digits after the dot [ Martín Ferrari ] * debian/watch: changed the quoting to fit PET's understanding of syntax, screw uscan! :) (see #515209.) There was also an error in the second regex. [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ gregor herrmann ] * Change my email address. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Florian Schlichting ] * Added remove_scary_notice.patch. * Switched to source format 3.0 (quilt). * Refreshed debian/copyright. * Bumped Standards-Version to 3.9.3 (deleted versioning on ancient perl). * Bumped debhelper compatibility to 9 (use hardening flags). * Switched to short debian/rules. * Added build-dependency on libtest-pod-perl to enable t/99_pod.t. * Expanded long description by a few lines. * Added myself to Uploaders.

    2008-01-27 - gregor herrmann <gregor+debian@comodo.priv.at> libterm-size-perl (0.2-4) unstable; urgency=low [ gregor herrmann ] The 'ready for perl 5.10' release. * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). Removed: XS- Vcs-Svn fields. * debian/control: add ${perl:Depends} (and ${misc:Depends}) to Depends to make the package pick up to correct dependency on perlapi; remove "-V" from dh_perl call in debian/rules. * Set Standards-Version to 3.7.3 (no changes). * Set debhelper compatibility level to 6. * debian/watch: improve regexp for matching upstream tarballs. * debian/copyright: rewrite from scratch. * debian/rules: - don't install empty /usr/share/perl5 directory if it exists - use $(CURDIR) instead of `pwd` - don't ignore errors of $(MAKE) realclean - move tests to build target - delete unused/unneeded dh_* calls - remove DESTDIR variable - move dh_clean before make distclean - use dh_clean to remove -stamp files - introduce install-stamp target depending on build-stamp - use "$@" for touching stamp files - use PREFIX and DESTDIR in call to make install - don't install README any more [ Damyan Ivanov ] * also remove unused dh_installdirs call

    2006-09-15 - gregor herrmann <gregor+debian@comodo.priv.at> libterm-size-perl (0.2-3) unstable; urgency=low * New Maintainer: Debian Perl Group. * Set Standards-Version to 3.7.2 (no changes). * Add watch file. * Activate tests in debian/rules.

    2006-03-16 - David Moreno Garza <damog@debian.org> libterm-size-perl (0.2-2) unstable; urgency=low * Adopting package (Closes: #357073).

    2003-02-15 - Chip Salzenberg <chip@debian.org> libterm-size-perl (0.2-1) unstable; urgency=low * Initial Release.

    Advertisement
    Advertisement