libterm-clui-perl_1.69-1_all.deb


Advertisement

Description

libterm-clui-perl - Perl module offering a Command-Line User Interface

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libterm-clui-perl
Package version: 1.69
Package release: 1
Package architecture: all
Package type: deb
Installed size: 161 B
Download size: 56.07 KB
Official Mirror: ftp.br.debian.org
Term::Clui offers a high-level user interface to give the user of command-line applications a consistent "look and feel". Its metaphor for the computer is as a human-like conversation-partner, and as each question/response is completed it is summarised onto one line, and remains on screen, so that the history of the session gradually accumulates on the screen and is available for review, or for cut/paste. This user interface can therefore be intermixed with standard applications which write to STDOUT or STDERR, such as make, pgp, rcs etc.

Alternatives

    Download

    Source package: libterm-clui-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libterm-clui-perl deb package:
      # sudo apt-get install libterm-clui-perl

    Files

    • /usr/share/doc/libterm-clui-perl/README
    • /usr/share/doc/libterm-clui-perl/changelog.Debian.gz
    • /usr/share/doc/libterm-clui-perl/changelog.gz
    • /usr/share/doc/libterm-clui-perl/copyright
    • /usr/share/doc/libterm-clui-perl/examples/audio_stuff.gz
    • /usr/share/doc/libterm-clui-perl/examples/choose
    • /usr/share/doc/libterm-clui-perl/examples/linux_admin.gz
    • /usr/share/doc/libterm-clui-perl/examples/login_shell.gz
    • /usr/share/doc/libterm-clui-perl/examples/test_script.gz
    • /usr/share/lintian/overrides/libterm-clui-perl
    • /usr/share/man/man3/Term::Clui.3pm.gz
    • /usr/share/man/man3/Term::Clui::FileSelect.3pm.gz
    • /usr/share/perl5/Term/Clui.pm
    • /usr/share/perl5/Term/Clui/FileSelect.pm

    Changelog

    2014-07-12 - gregor herrmann <gregoa@debian.org> libterm-clui-perl (1.69-1) unstable; urgency=medium * Team upload. * New upstream release. * Strip trailing slash from metacpan URLs. * Declare compliance with Debian Policy 3.9.5.

    2013-09-28 - Axel Beckert <abe@debian.org> libterm-clui-perl (1.68-1) unstable; urgency=low * Team upload. * New upstream release [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * Add lintian override for perl-module-uses-perl4-libs-without-dep * Bump Standards-Version to 3.9.4 (no changes) * Bump debhelper compatibility to 9 + Update versioned debhelper compatibility accordingly + Gets rid of the dh_pysupport deprecation warning

    2012-10-03 - Mathieu Malaterre <malat@debian.org> libterm-clui-perl (1.66-1) unstable; urgency=low * Initial Release. (Closes: #689504)

    Advertisement
    Advertisement