libtelnet-dev_0.21-4_amd64.deb


Advertisement

Description

libtelnet-dev - Small library for parsing the TELNET protocol - development files

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtelnet-dev
Package version: 0.21
Package release: 4
Package architecture: amd64
Package type: deb
Installed size: 98 B
Download size: 25.27 KB
Official Mirror: ftp.br.debian.org
libtelnet is a small library for parsing the TELNET protocol, responding to TELNET commands via an event interface, and generating valid TELNET commands. libtelnet includes support for the non-official MCCP, MCCP2, ZMP, and MSSP protocols used by MUD servers and clients. This package contains the libtelnet development support files.

Alternatives

    Download

    Source package: libtelnet

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtelnet-dev deb package:
      # sudo apt-get install libtelnet-dev

    Files

    • /usr/include/libtelnet.h
    • /usr/lib/libtelnet.a
    • /usr/lib/libtelnet.so
    • /usr/lib/pkgconfig/libtelnet.pc
    • /usr/share/doc/libtelnet-dev/AUTHORS
    • /usr/share/doc/libtelnet-dev/NEWS.gz
    • /usr/share/doc/libtelnet-dev/README.gz
    • /usr/share/doc/libtelnet-dev/changelog.Debian.gz
    • /usr/share/doc/libtelnet-dev/changelog.gz
    • /usr/share/doc/libtelnet-dev/copyright

    Changelog

    2014-09-02 - Ralph Lange <Ralph.Lange@gmx.de> libtelnet (0.21-4) unstable; urgency=low * Patch to disable -Werror when autoreconf'ing * Use dh-autoreconf instead of autotools-dev to fix FTBFS on ppc64el (Closes: #734217)

    2013-10-28 - Ralph Lange <Ralph.Lange@gmx.de> libtelnet (0.21-3) unstable; urgency=low * d/watch: fix Github URL

    2013-10-28 - Ralph Lange <Ralph.Lange@gmx.de> libtelnet (0.21-2) unstable; urgency=low * d/control: fix Vcs-*: links to use canonical URLs * d/control: bump Standards-Version: to 3.9.5 with no changes * Update config.{guess,sub} using autotools-dev (Closes: #727442)

    2012-06-06 - Ralph Lange <Ralph.Lange@gmx.de> libtelnet (0.21-1) unstable; urgency=low * Import upstream version 0.21 * d/control: fix Vcs-Browser: link * d/control: add build-dependency on pkg-config * d/rules: add "--as-needed" to LDFLAGS to avoid overlinking * d/rules: add hardening flags * d/format, d/control: add quilt * Patch missing config.h include (reported to upstream) * Patch wrong version number definition (reported to upstream)

    2012-03-15 - Ralph Lange <Ralph.Lange@gmx.de> libtelnet (0.20-1) unstable; urgency=low * Initial release (Closes: #662972)

    Advertisement
    Advertisement