libteam5_1.12-2_amd64.deb


Advertisement

Description

libteam5 - library for communication with Netlink kernel module

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libteam5
Package version 1.12
Package release 2
Package architecture amd64
Package type deb
Installed size 94 B
Download size 21.93 KB
Official Mirror ftp.br.debian.org
"libteam" is a library for communication with kernel module (Netlink).
It is used by `teamd`.
Libteam provide mechanism to team multiple NICs (ports) into one
logical one (teamdev) at L2 layer. The process is called "channel
bonding", "Ethernet bonding", "channel teaming", "link aggregation",
etc. This is already implemented in the Linux kernel by the bonding
driver but unlike bonding driver libteam (user space) have the
following additional features:
* load-balancing for LACP support
* NS/NA (IPV6) link monitoring
* port priorities and stickiness ("primary" option enhancement)
* separate per-port link monitoring setup
Libteam requires Linux kernel 3.3 or higher.

Alternatives

Package Version Architecture Repository
libteam5_1.12-2_i386.deb 1.12 i386 Debian Main
libteam5 - - -

Requires

Name Value
libc6 >= 2.15
libnl-3-200 >= 3.2.7
libnl-cli-3-200 >= 3.2.7
libnl-genl-3-200 >= 3.2.7
libnl-nf-3-200 >= 3.2.7
libnl-route-3-200 >= 3.2.24
multiarch-support -

Download

Type URL
Binary Package libteam5_1.12-2_amd64.deb
Source Package libteam

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libteam5 deb package:
    # sudo apt-get install libteam5

Files

Path
/usr/lib/x86_64-linux-gnu/libteam.so.5
/usr/lib/x86_64-linux-gnu/libteam.so.5.2.0
/usr/share/doc/libteam5/README.Debian
/usr/share/doc/libteam5/changelog.Debian.gz
/usr/share/doc/libteam5/copyright

Changelog

2015-03-25 - Dmitry Smirnov <onlyjob@debian.org>
libteam (1.12-2) unstable; urgency=medium
* "libteam-dev" to Depend on "libnl-3-dev" (Closes: #780855).
Thanks, Marco d'Itri.
2014-08-31 - Dmitry Smirnov <onlyjob@debian.org>
libteam (1.12-1) unstable; urgency=low
* New upstream release [August 2014].
* Minor "debian/control" cleanup: "git" removed from Build-Depends.
2014-07-05 - Dmitry Smirnov <onlyjob@debian.org>
libteam (1.11-1) unstable; urgency=low
* New upstream release [June 2014].
* Upload to unstable.
* Added "debian/gbp.conf".
2014-04-05 - Dmitry Smirnov <onlyjob@debian.org>
libteam (1.10-1) experimental; urgency=low
* New upstream release [April 2014].
* TODO.Debian: added note to install init scripts.
2013-12-05 - Dmitry Smirnov <onlyjob@debian.org>
libteam (1.9-1) experimental; urgency=low
* New upstream release [November 2013].
- dropped all patches (applied-upstream).
* "debian/rules": don't try to extract/check ABI/Soname numbers.
* Standards to 3.9.5
* Updated Homepage URL.
2013-10-12 - Dmitry Smirnov <onlyjob@debian.org>
libteam (1.8-1) experimental; urgency=low
* Initial release (Closes: #695850).

See Also

Package Description
libteamdctl0_1.12-2_amd64.deb library for communication with `teamd` process
libtecla-dev_1.6.2-2_amd64.deb interactive command line editing facilities (development)
libtecla1_1.6.2-2_amd64.deb interactive command line editing facilities
libteem-dev_1.11.0~svn5226-1_amd64.deb Tools to process and visualize scientific data and images - development
libteem2_1.11.0~svn5226-1_amd64.deb Tools to process and visualize scientific data and images - runtime
libtelepathy-farstream-dev_0.6.2-1_amd64.deb Glue library between telepathy and farstream (development files)
libtelepathy-farstream-doc_0.6.2-1_all.deb Glue library between telepathy and farstream (documentation)
libtelepathy-farstream3_0.6.2-1_amd64.deb Glue library between telepathy and farstream
libtelepathy-glib-dev_0.24.1-1_amd64.deb GLib Telepathy connection manager library (headers)
libtelepathy-glib-doc_0.24.1-1_all.deb GLib Telepathy library (documentation)
libtelepathy-glib0_0.24.1-1_amd64.deb Telepathy framework - GLib library
libtelepathy-logger-dev_0.8.1-1_amd64.deb Telepathy logger service -- utility library (headers)
libtelepathy-logger-doc_0.8.1-1_all.deb Telepathy logger service -- documentation
libtelepathy-logger-qt4-1_0.8.0-3_amd64.deb Qt bindings for the telepathy-logger library
libtelepathy-logger-qt4-dev_0.8.0-3_amd64.deb Qt bindings for the telepathy-logger library - development files
Advertisement
Advertisement