libtap-parser-sourcehandler-pgtap-perl_3.29-1_all.deb


Advertisement

Description

libtap-parser-sourcehandler-pgtap-perl - Unit testing tools for pgTAP

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libtap-parser-sourcehandler-pgtap-perl
Package version: 3.29
Package release: 1
Package architecture: all
Package type: deb
Installed size: 118 B
Download size: 31.97 KB
Official Mirror: ftp.br.debian.org
TAP::Parser::SourceHandler::pgTAP is a set of tools for PostgreSQL unit testing. It contains the pg_prove and pg_tapgen scripts, which allows running and harnessing pgTAP tests on command-line, and summarizing the results. TAP is the Test Anything Protocol (http://testanything.org/).

Conflicts

  • pgtap <= 0.24-1

    Download

    Source package: libtap-parser-sourcehandler-pgtap-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libtap-parser-sourcehandler-pgtap-perl deb package:
      # sudo apt-get install libtap-parser-sourcehandler-pgtap-perl

    Files

    • /usr/bin/pg_prove
    • /usr/bin/pg_tapgen
    • /usr/share/doc/libtap-parser-sourcehandler-pgtap-perl/README
    • /usr/share/doc/libtap-parser-sourcehandler-pgtap-perl/README.Debian
    • /usr/share/doc/libtap-parser-sourcehandler-pgtap-perl/changelog.Debian.gz
    • /usr/share/doc/libtap-parser-sourcehandler-pgtap-perl/changelog.gz
    • /usr/share/doc/libtap-parser-sourcehandler-pgtap-perl/copyright
    • /usr/share/man/man1/pg_prove.1p.gz
    • /usr/share/man/man1/pg_tapgen.1p.gz
    • /usr/share/man/man3/TAP::Parser::SourceHandler::pgTAP.3pm.gz
    • /usr/share/perl5/TAP/Parser/SourceHandler/pgTAP.pm

    Changelog

    2013-12-29 - Pierre Chifflier <pollux@debian.org> libtap-parser-sourcehandler-pgtap-perl (3.29-1) unstable; urgency=low * Imported Upstream version 3.29 * Use less stricter Build-Dep on libtest-harness-perl (Closes: #669094) * Bump Standards Version to 3.9.5

    2012-06-10 - Pierre Chifflier <pollux@debian.org> libtap-parser-sourcehandler-pgtap-perl (3.27-2) unstable; urgency=medium * Update build-dependencies, libtest-harness-perl is now part of perl-modules (Closes: #676758)

    2012-03-01 - Pierre Chifflier <pollux@debian.org> libtap-parser-sourcehandler-pgtap-perl (3.27-1) unstable; urgency=low * Imported Upstream version 3.27 (Closes: #661763) * Bump Standards Version to 3.9.3 * Add libtest-pod-perl to build-deps * Switch to DH version 9 * Add watch file

    2011-03-28 - Pierre Chifflier <pollux@debian.org> libtap-parser-sourcehandler-pgtap-perl (3.25-1) unstable; urgency=low * Initial release (Closes: #619925)

    Advertisement
    Advertisement