libsys-syslog-perl_0.33-1+deb8u1_amd64.deb


Advertisement

Description

libsys-syslog-perl - Perl interface to the UNIX syslog(3) calls

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libsys-syslog-perl
Package version: 0.33
Package release: 1+deb8u1
Package architecture: amd64
Package type: deb
Installed size: 154 B
Download size: 40.32 KB
Official Mirror: ftp.br.debian.org
Sys::Syslog is an interface to the UNIX syslog(3) program. Call syslog() with a string priority and a list of printf() args just like syslog(3). Note that an earlier version of this module is included in the perl package, and this one will override it when installed. Please don't depend on this package unnecessarily if the older one is enough.

Alternatives

    Download

    Source package: libsys-syslog-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libsys-syslog-perl deb package:
      # sudo apt-get install libsys-syslog-perl

    Files

    • /usr/lib/x86_64-linux-gnu/perl5/5.20/Sys/Syslog.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Sys/Syslog/Syslog.so
    • /usr/share/doc/libsys-syslog-perl/changelog.Debian.gz
    • /usr/share/doc/libsys-syslog-perl/changelog.gz
    • /usr/share/doc/libsys-syslog-perl/copyright
    • /usr/share/doc/libsys-syslog-perl/examples/syslog.pl
    • /usr/share/man/man3/Sys::Syslog.3pm.gz

    Changelog

    2016-07-24 - Dominic Hargreaves <dom@earth.li> libsys-syslog-perl (0.33-1+deb8u1) jessie-security; urgency=high * Team upload. * Remove . from @INC when loading modules dynamically [CVE-2016-1238]

    2013-09-14 - gregor herrmann <gregoa@debian.org> libsys-syslog-perl (0.33-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Don't run author tests during package build. [ Axel Beckert ] * debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg- copyright" [ gregor herrmann ] * New upstream release. * Update years of copyright. * Use debhelper 9.20120312 to get all hardening flags. * Declare compliance with Debian Policy 3.9.4.

    2011-04-19 - gregor herrmann <gregoa@debian.org> libsys-syslog-perl (0.29-1) unstable; urgency=low [ Jonathan Yu ] * Removed Alexis Sukrieh from Uploaders (Closes: #536160) [ gregor herrmann ] * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). [ Rene Mayorga ] * Email change: Rene Mayorga -> rmayorga@debian.org [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Ansgar Burchardt ] * Email change: Ansgar Burchardt -> ansgar@debian.org [ gregor herrmann ] * New upstream release (closes: #603251). * Switch to source format 3.0 (quilt); remove quilt framework. * Bump debhelper compatibility level to 8; use short dh debian/rules file. * Set Standards-Version to 3.9.2 (no changes). * Remove patch fix-man-page-line-too-long.patch, no longer needed. * debian/copyright: update years of upstream copyright and formatting. * debian/control: add libtest-portability-files-perl to Build-Depends. * Email change: Niko Tyni -> ntyni@debian.org

    2008-09-22 - Ansgar Burchardt <ansgar@43-1.org> libsys-syslog-perl (0.27-1) unstable; urgency=low [ Ansgar Burchardt ] * New upstream release. * Add myself to Uploaders. * Convert debian/copyright to proposed machine-readable format. * Refresh debian/rules for debhelper 7 * Replace debian/README.source with a longer version [ gregor herrmann ] * debian/copyright: add information about fallback/syslog.h. * debian/rules: enable additional tests; leads to: * Strip URL mangling from fix-man-page-line-too-long.patch, lintian does not complain about them any more but Pod::Checker didn't like the syntax.

    2008-06-17 - gregor herrmann <gregoa@debian.org> libsys-syslog-perl (0.26-1) unstable; urgency=low * New upstream release. * debian/copyright: update years of copyright, correcty a small typo. * Refresh and extend patch fix-man-page-line-too-long.patch. * debian/control: change my email address. * Set Standards-Version to 3.8.0; add debian/README.source accordingly. * Make dependency on quilt versioned. * Refresh debian/rules, no functional changes. Don't install README any more.

    2008-01-01 - gregor herrmann <gregor+debian@comodo.priv.at> libsys-syslog-perl (0.24-1) unstable; urgency=low * New upstream release. * Drop patch skip-test-that-needs-dev-log.dpatch, the problem is now fixed in the upstream test code. * Set Standards-Version to 3.7.3 (no changes needed). * debian/watch: use dist-based URL. * debian/rules: remove /usr/share/perl5 only if it exists.

    2007-11-17 - gregor herrmann <gregor+debian@comodo.priv.at> libsys-syslog-perl (0.23-1) unstable; urgency=low [ gregor herrmann ] * New upstream release. * Update patch skip-test-that-needs-dev-log.dpatch. [ Damyan Ivanov ] * Fix usage of DESTDIR and PREFIX when invoking $(MAKE) install * Use '$@' when touching stamps * Re-wrapped Uploaders * Add dh_shlibdeps; add ${shlibs:Depends} and ${misc:Depends} to Depends

    Advertisement
    Advertisement