libswish-api-common-perl_0.04-1_all.deb


Advertisement

Description

libswish-api-common-perl - Perl interface to the SWISH index engine

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libswish-api-common-perl
Package version 0.04
Package release 1
Package architecture all
Package type deb
Installed size 61 B
Download size 10.17 KB
Official Mirror ftp.br.debian.org
SWISH::API::Common offers an easy interface to the Swish index engine. While
SWISH::API offers a complete API, SWISH::API::Common focuses on ease of use.
Currently, this API allows for indexing documents in a single directory and
any of its subdirectories. However, index() and search() cannot be executed
in parallel.

Alternatives

Package Version Architecture Repository
libswish-api-common-perl_0.04-1_all.deb 0.04 all Debian Main
libswish-api-common-perl - - -

Requires

Name Value
liblog-log4perl-perl -
libsysadm-install-perl -
libwww-perl -
perl -
swish-e -

Download

Type URL
Binary Package libswish-api-common-perl_0.04-1_all.deb
Source Package libswish-api-common-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libswish-api-common-perl deb package:
    # sudo apt-get install libswish-api-common-perl

Files

Path
/usr/share/doc/libswish-api-common-perl/changelog.Debian.gz
/usr/share/doc/libswish-api-common-perl/changelog.gz
/usr/share/doc/libswish-api-common-perl/copyright
/usr/share/man/man3/SWISH::API::Common.3pm.gz
/usr/share/perl5/SWISH/API/Common.pm

Changelog

2014-03-12 - Axel Beckert <abe@debian.org>
libswish-api-common-perl (0.04-1) unstable; urgency=low
* Team upload
[ Jonathan Yu ]
* New upstream release
+ Fix bug in 30fix-makefile-pl.patch (RT#48597)
* Bump compat to debhelper 7. Use new short rules format
* Remove patches applied upstream
* Rewrote control description
* Update to machine readable copyright format
* Added myself to Uploaders, replacing "TODO" placeholder. If
anyone else is interested, please add yourself.
[ gregor herrmann ]
* Add debian/README.source to document quilt usage, as required by
Debian Policy since 3.8.0.
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
* Remove Florian Ragwitz from Uploaders (closes: #523297).
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ryan Niebur ]
* Update jawnsy's email address
[ gregor herrmann ]
* debian/rules: switch order of arguments to dh.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Axel Beckert ]
* Switch to source format "3.0 (quilt)"
+ Drop README.source, quilt B-D and "--with quilt" dh parameter
* Fix lintian warning copyright-refers-to-symlink-license
* Bump Standards-Version to 3.9.5 (no changes)
2008-07-08 - Frank Lichtenheld <djpig@debian.org>
libswish-api-common-perl (0.03-2) unstable; urgency=medium
[ gregor herrmann ]
* Take over for the Debian Perl Group with maintainer's permission
(http://lists.debian.org/debian-perl/2008/06/msg00039.html)
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Changed:
Maintainer set to Debian Perl Group <pkg-perl-
maintainers@lists.alioth.debian.org> (was: Florian Ragwitz
<rafl@debianforum.de>); Florian Ragwitz <rafl@debianforum.de> moved
to Uploaders.
* Add debian/watch.
* Switch patch system from dpatch to quilt.
[ Frank Lichtenheld ]
* Provide a &VERSION subroutine since somehow SWISH::API manages to wreck
the one we get from UNIVERSAL which causes FTBFS in other packages.
* Don't ignore errors from make distclean
2008-05-27 - Gunnar Wolf <gwolf@debian.org>
libswish-api-common-perl (0.03-1.1) unstable; urgency=low
* Non-maintainer upload.
* Fixed two FTBFS for the price of one! ;-)
* FTBFS: Typo in Makefile.PL (Closes: #467482)
* FTBFS: No longer dies trying to remove nonexisting directory
/usr/lib/perl5 (perl 5.10 transition)
2005-08-23 - Florian Ragwitz <rafl@debianforum.de>
libswish-api-common-perl (0.03-1) unstable; urgency=low
* Initial Release (Closes: #324732).

See Also

Package Description
libswiss-perl_1.67-1_all.deb Perl API to the UniProt database
libswitch-perl_2.17-2_all.deb switch statement for Perl
libsword-common_1.7.3+dfsg-2_all.deb common settings and module repository for libsword
libsword-dev_1.7.3+dfsg-2_amd64.deb Development files for libsword
libsword-utils_1.7.3+dfsg-2_amd64.deb conversion utilities for bible documents in SWORD supported formats
libsword11_1.7.3+dfsg-2_amd64.deb API/library for bible software
libswscale-dev_11.12-1~deb8u1_amd64.deb Development files for libswscale
libswscale3_11.12-1~deb8u1_amd64.deb Libav video scaling library
libswt-cairo-gtk-3-jni_3.8.2-3_amd64.deb Standard Widget Toolkit for GTK+ Cairo JNI library
libswt-cairo-gtk-4-jni_4.3.2-1_amd64.deb Standard Widget Toolkit for GTK+ Cairo JNI library
libswt-glx-gtk-3-jni_3.8.2-3_amd64.deb Standard Widget Toolkit for GTK+ GLX JNI library
libswt-glx-gtk-4-jni_4.3.2-1_amd64.deb Standard Widget Toolkit for GTK+ GLX JNI library
libswt-gnome-gtk-3-jni_3.8.2-3_amd64.deb Standard Widget Toolkit for GTK+ GNOME JNI library
libswt-gnome-gtk-4-jni_4.3.2-1_amd64.deb Standard Widget Toolkit for GTK+ GNOME JNI library
libswt-gtk-3-java-gcj_3.8.2-3_amd64.deb Standard Widget Toolkit for GTK+ native library
Advertisement
Advertisement