libsvnclientadapter-java_1.10.3-2_all.deb


Advertisement

Description

libsvnclientadapter-java - High-level Java API for Subversion (library)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libsvnclientadapter-java
Package version 1.10.3
Package release 2
Package architecture all
Package type deb
Installed size 196 B
Download size 148.95 KB
Official Mirror ftp.br.debian.org
SVNClientAdapter is a high-level Java API for Subversion.
It can use one of 3 low-level svn client implementations to provide access to
the Subversion API:
- JavaHL native (JNI) Subversion library
<http://svn.collab.net/repos/svn/trunk/subversion/bindings/java/javahl/>
- JavaSVN (pure Java) Subversion API implementation
<http://tmate.org/svn/>
- svn command line client wrapper
This package contains the SvnClientAdapter library.

Alternatives

Package Version Architecture Repository
libsvnclientadapter-java_1.10.3-2_all.deb 1.10.3 all Debian Main
libsvnclientadapter-java - - -

Requires

Name Value
libsvn-java >= 1.8~
libsvnkit-java >= 1.7.5~

Provides

Name Value
libnb-svnclientadapter-java -

Conflicts

Name Value
libnb-svnclientadapter-java -

Replaces

Name Value
libnb-svnclientadapter-java -

Download

Type URL
Binary Package libsvnclientadapter-java_1.10.3-2_all.deb
Source Package svnclientadapter

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsvnclientadapter-java deb package:
    # sudo apt-get install libsvnclientadapter-java

Files

Path
/usr/share/doc/libsvnclientadapter-java/changelog.Debian.gz
/usr/share/doc/libsvnclientadapter-java/changelog.gz
/usr/share/doc/libsvnclientadapter-java/copyright
/usr/share/java/svnClientAdapter-1.10.3.jar
/usr/share/java/svnClientAdapter.jar

Changelog

2014-08-30 - Emmanuel Bourg <ebourg@apache.org>
svnclientadapter (1.10.3-2) unstable; urgency=medium
* Team upload.
* Removed the build dependency on libemma-java
* Removed Andres Mejia from the uploaders (Closes: #743539)
* Switch to debhelper level 9
2014-02-22 - Jakub Adam <jakub.adam@ktknet.cz>
svnclientadapter (1.10.3-1) unstable; urgency=medium
* New upstream release.
* Refresh d/patches/subclipse-load-nativelib-from-single-bundle.patch.
* Depend on libsvn-java (>= 1.8~).
* Bump Standards-Version to 3.9.5.
* Use xz for upstream tarball compression.
* Make Vcs-* fields canonical.
2013-06-28 - Niels Thykier <niels@thykier.net>
svnclientadapter (1.8.16-2) unstable; urgency=low
* Team upload to unstable.
2012-10-14 - Jakub Adam <jakub.adam@ktknet.cz>
svnclientadapter (1.8.16-1) experimental; urgency=low
* New Upstream release.
* Add Jakub Adam to Uploaders.
* Build depend on libsvn-java (>= 1.7.5~).
* Disable commandline SVN client wrapper.
- Seems upstream stopped maintaining commandline SVN client wrapper
and it now became uncompilable as a result.
* Use real version number during build.
* Bump Standards-Version to 3.9.3.
* Remove dependency on libganymed-ssh2-java.
- Was a dependency of old SVNKit version, not needed anymore.
* Don't depend on both JavaHL and SVNKit, require only one of them to
be installed.
* Remove emma.jar and emma_ant.jar from Class-Path, they are required
only for running tests.
* Refreshed d/patches/packaging-changes.patch.
* Use bnd to generate OSGi metadata.
2011-07-17 - Andres Mejia <amejia@debian.org>
svnclientadapter (0.9.100-2) unstable; urgency=low
[ Andres Mejia ]
* Update to my @debian.org email.
[ Jakub Adam ]
* Add OSGi metadata to JAR manifest
* Fix compatibility with eclipse-subclipse
* Bump to Standards-Version 3.9.2.
* Increase debhelper compatibility to 8.
2011-01-22 - Andres Mejia <mcitadel@gmail.com>
svnclientadapter (0.9.100-1) unstable; urgency=low
[ Andres Mejia ]
* Initial release. (Closes: #374257)
[ Damien Raude-Morvan ]
* d/control: Drop Depends: default-jre | java2-runtime
as a Java library don't need to depends on runtime (Java Policy).
* d/control: Fix indentation for long description.

See Also

Package Description
libsvncpp-dev_0.12.1dfsg-2_amd64.deb Subversion C++ library (development files)
libsvncpp3_0.12.1dfsg-2_amd64.deb Subversion C++ shared library
libsvnkit-java-doc_1.8.6-1_all.deb documentation for libsvnkit-java
libsvnkit-java_1.8.6-1_all.deb pure Java Subversion client library
libsvnqt-dev_1.6.0-2_amd64.deb Qt wrapper library for Subversion (development files)
libsvnqt7_1.6.0-2_amd64.deb Qt wrapper library for Subversion
libsvrcore-dev_4.0.4-15_amd64.deb Development files for Netscape's secure PIN storage library
libsvrcore0_4.0.4-15_amd64.deb Netscape's secure PIN storage library
libswami-dev_2.0.0+svn389-3_amd64.deb MIDI instrument editor - development files
libswami0_2.0.0+svn389-3_amd64.deb MIDI instrument editor - shared libraries
libswarmcache-java_1.0RC2+cvs20071027-7_all.deb SwarmCache - Distributed caching mechanism for Java
libswe-dev_1.80.00.0002-1_amd64.deb C library for The Swiss Ephemeris
libswe-doc_1.80.00.0001-1_all.deb documentation for the libswe package
libswe0_1.80.00.0002-1_amd64.deb C library for the Swiss Ephemeris
libswiften-dev_2.0+dev6-1+b1_amd64.deb XMPP library (development files)
Advertisement
Advertisement