libsub-infix-perl_0.004-1_all.deb


Advertisement

Description

libsub-infix-perl - create a fake infix operator

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libsub-infix-perl
Package version: 0.004
Package release: 1
Package architecture: all
Package type: deb
Installed size: 26 B
Download size: 10.65 KB
Official Mirror: ftp.br.debian.org
Sub::Infix creates fake infix operators using overloading. It doesn't use source filters, or Devel::Declare, or any of that magic. (Though Devel::Declare isn't magic enough to define infix operators anyway; I know; I've tried.) It's pure Perl, has no non-core dependencies, and runs on Perl 5.8.

Alternatives

Requires

    Download

    Source package: libsub-infix-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libsub-infix-perl deb package:
      # sudo apt-get install libsub-infix-perl

    Files

    • /usr/share/doc/libsub-infix-perl/CREDITS
    • /usr/share/doc/libsub-infix-perl/README
    • /usr/share/doc/libsub-infix-perl/buildinfo_all.gz
    • /usr/share/doc/libsub-infix-perl/changelog.Debian.gz
    • /usr/share/doc/libsub-infix-perl/changelog.gz
    • /usr/share/doc/libsub-infix-perl/copyright
    • /usr/share/man/man3/Sub::Infix.3pm.gz
    • /usr/share/perl5/Sub/Infix.pm

    Changelog

    2014-08-27 - Jonas Smedegaard <dr@jones.dk> libsub-infix-perl (0.004-1) unstable; urgency=medium [ upstream ] * New release. + Backport to Perl 5.6. [ Salvatore Bonaccorso ] * Update Vcs-Browser URL to cgit web frontend [ Jonas Smedegaard ] * Update copyright info: + Extend coverage for main upstream author to include earlier year. + Drop obsolete comment about CONTRIBUTING file. * Adjust long description to reflect support for Perl 5.6.

    2014-05-30 - Jonas Smedegaard <dr@jones.dk> libsub-infix-perl (0.003-2) unstable; urgency=medium * Update copyright info: + Fix cover CONTRIBUTING file. Thanks to Thorsten Alteholz.

    2014-05-18 - Jonas Smedegaard <dr@jones.dk> libsub-infix-perl (0.003-1) unstable; urgency=medium [ upstream ] * New release. + Use build system Dist::Inkt. + Don't use base.pm. [ Jonas Smedegaard ] * Bump to standards-version 3.9.5. * Fix use canonical Vcs-Git URL. * Update copyright info: + Extend coverage for main upstream author, and of packaging. + Drop Files sections for no longer shipped convenience code copies. * Update watch file to use metacpan.org URL.

    2013-07-01 - Jonas Smedegaard <dr@jones.dk> libsub-infix-perl (0.002-1) unstable; urgency=low * Initial packaging release. Closes: bug#714627.

    Advertisement
    Advertisement