libsub-exporter-globexporter-perl_0.003-1_all.deb


Advertisement

Description

libsub-exporter-globexporter-perl - module for exporting shared globs

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libsub-exporter-globexporter-perl
Package version 0.003
Package release 1
Package architecture all
Package type deb
Installed size 53 B
Download size 6.98 KB
Official Mirror ftp.br.debian.org
Sub::Exporter::GlobExporter is a Perl module that enables packages to share
glob references with other modules. This allows your module to be subclassed,
for the subclass to re-use the same glob when exporting, or to export a new
one. This scheme provides extensibility by returning a collection validator,
allowing arbitrary options to be passed to the globref locator.

Alternatives

Package Version Architecture Repository
libsub-exporter-globexporter-perl_0.003-1_all.deb 0.003 all Debian Main
libsub-exporter-globexporter-perl - - -

Requires

Name Value
libsub-exporter-perl -
perl -

Download

Type URL
Binary Package libsub-exporter-globexporter-perl_0.003-1_all.deb
Source Package libsub-exporter-globexporter-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsub-exporter-globexporter-perl deb package:
    # sudo apt-get install libsub-exporter-globexporter-perl

Files

Path
/usr/share/doc/libsub-exporter-globexporter-perl/changelog.Debian.gz
/usr/share/doc/libsub-exporter-globexporter-perl/changelog.gz
/usr/share/doc/libsub-exporter-globexporter-perl/copyright
/usr/share/man/man3/Sub::Exporter::GlobExporter.3pm.gz
/usr/share/perl5/Sub/Exporter/GlobExporter.pm

Changelog

2013-09-20 - Florian Schlichting <fsfs@debian.org>
libsub-exporter-globexporter-perl (0.003-1) unstable; urgency=low
* Team upload
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ Florian Schlichting ]
* Import Upstream version 0.003
* Bump Standards-Version to 3.9.4 (no change)
2011-02-28 - Jonathan Yu <jawnsy@cpan.org>
libsub-exporter-globexporter-perl (0.002-1) unstable; urgency=low
* Initial Release (Closes: #615925)

See Also

Package Description
libsub-exporter-perl_0.986-1_all.deb sophisticated exporter for custom-built routines
libsub-exporter-progressive-perl_0.001011-1_all.deb module for using Sub::Exporter only if needed
libsub-identify-perl_0.08-1_amd64.deb module to retrieve names of code references
libsub-infix-perl_0.004-1_all.deb create a fake infix operator
libsub-install-perl_0.928-1_all.deb module for installing subroutines into packages easily
libsub-name-perl_0.12-1_amd64.deb module for assigning a new name to referenced sub
libsub-override-perl_0.09-1_all.deb Perl module used to temporarily override subroutines
libsub-prototype-perl_0.02-2+b1_amd64.deb module to set a subroutine's prototype
libsub-recursive-perl_0.03-1_all.deb Perl module for memory-leak free recursive anonymous subroutines
libsub-uplevel-perl_0.2400-1_all.deb module to spoof the Perl call stack
libsub-wrappackages-perl_2.0-1_all.deb module to wrap subroutines in packages
libsublib-cil_0.9-4_all.deb CLI library that eases the development of subtitling applications
libsublime-dev_1.7.0-2_amd64.deb development files for the sublime user interface library
libsublime8_1.7.0-2_amd64.deb User interface library
libsubtitleeditor-dev_0.33.0-3_amd64.deb subtitleeditor lib - development files
Advertisement
Advertisement