libstruct-compare-perl_1.0.1-3_all.deb


Advertisement

Description

libstruct-compare-perl - Perl module providing recursive diff for perl structures

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libstruct-compare-perl
Package version: 1.0.1
Package release: 3
Package architecture: all
Package type: deb
Installed size: 60 B
Download size: 7.66 KB
Official Mirror: ftp.br.debian.org
Struct::Compare compares two values of any type and structure and returns true if they are the same. It does a deep comparison of the structures, so a hash of a hash of a whatever will be compared correctly. This is especially useful for writing unit tests for your modules!

Alternatives

Requires

    Download

    Source package: libstruct-compare-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libstruct-compare-perl deb package:
      # sudo apt-get install libstruct-compare-perl

    Files

    • /usr/share/doc/libstruct-compare-perl/changelog.Debian.gz
    • /usr/share/doc/libstruct-compare-perl/changelog.gz
    • /usr/share/doc/libstruct-compare-perl/copyright
    • /usr/share/man/man3/Struct::Compare.3pm.gz
    • /usr/share/perl5/Struct/Compare.pm

    Changelog

    2011-07-02 - Fabrizio Regalli <fabreg@fabreg.it> libstruct-compare-perl (1.0.1-3) unstable; urgency=low * Take over (see http://lists.debian.org/debian-perl/2011/07/msg00003.html). * Added Homepage and Vcs-* fields in d/control. * Bump to 3.9.2 Standard-Version. * Add myself to Uploaders and Copyright. * Switch d/compat to 8. * Build-Depends: switch to debhelper (>= 8). * Bump to 3.0 quilt format. * Added d/watch file. * Switch to DEP5 license format. * Fixed lintian description-synopsis-might-not-be-phrased-properly message. * Added pod2man patch.

    2008-04-05 - Mark Hymers <mhy@debian.org> libstruct-compare-perl (1.0.1-2.1) unstable; urgency=low * Non-maintainer upload. * Fix FTBFS with Perl 5.10. Closes: #467894

    2007-08-31 - Martin Zobel-Helas <zobel@debian.org> libstruct-compare-perl (1.0.1-2) unstable; urgency=low * Fix debian/copyright and list the license. Lets hope this satifies Ganneff to let this package through NEW.

    2007-08-16 - Martin Zobel-Helas <zobel@debian.org> libstruct-compare-perl (1.0.1-1) unstable; urgency=low * Initial Release.

    Advertisement
    Advertisement