libstring-truncate-perl_1.100602-1_all.deb


Advertisement

Description

libstring-truncate-perl - Perl module to truncate long strings

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libstring-truncate-perl
Package version 1.100602
Package release 1
Package architecture all
Package type deb
Installed size 58 B
Download size 10.11 KB
Official Mirror ftp.br.debian.org
String::Truncate is a Perl module useful for truncating any long string
sequence and marking the place where any text has been elided (deleted).
You simply tell the module the maximum string width and where to elide
strings (at the right side, left side, in the middle or at the ends). It
also supports a customized marker for elisions, but defaults to the most
common symbol, the ellipsis (...). It can also prefer to break strings at
whitespace where possible.

Alternatives

Package Version Architecture Repository
libstring-truncate-perl_1.100602-1_all.deb 1.100602 all Debian Main
libstring-truncate-perl - - -

Requires

Name Value
libsub-exporter-perl -
libsub-install-perl -
perl -

Download

Type URL
Binary Package libstring-truncate-perl_1.100602-1_all.deb
Source Package libstring-truncate-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libstring-truncate-perl deb package:
    # sudo apt-get install libstring-truncate-perl

Files

Path
/usr/share/doc/libstring-truncate-perl/changelog.Debian.gz
/usr/share/doc/libstring-truncate-perl/changelog.gz
/usr/share/doc/libstring-truncate-perl/copyright
/usr/share/man/man3/String::Truncate.3pm.gz
/usr/share/perl5/String/Truncate.pm

Changelog

2014-05-10 - gregor herrmann <gregoa@debian.org>
libstring-truncate-perl (1.100602-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Strip trailing slash from metacpan URLs.
* Update years of upstream copyright.
* Declare compliance with Debian Policy 3.9.5.
2013-10-23 - gregor herrmann <gregoa@debian.org>
libstring-truncate-perl (1.100601-1) unstable; urgency=low
* Team upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* New upstream release.
* Update years of upstream copyright.
* Declare compliance with Debian Policy 3.9.4.
2011-04-01 - Salvatore Bonaccorso <carnil@debian.org>
libstring-truncate-perl (1.100600-1) unstable; urgency=low
* Team upload.
* New upstream release
* Bump Debhelper compat level to 8.
* debian/control:
- Bump versioned Build-Depends on debhelper to (>= 8).
* debian/copyright:
- Update copyright years for upstream stanza.
- Update copyright for debian/* packaging
- Refer to GPL-1 license text in common-licenses. 
- Refer to Debian systems in general instead of only Debian
GNU/Linux systems.
* Bump Standards-Version to 3.9.1.
2010-03-01 - Franck Joncourt <franck@debian.org>
libstring-truncate-perl (1.100570-1) unstable; urgency=low
* New upstream release.
+ Removed BDI on libtest-pod-coverage-perl, libtest-pod-perl. Theses
modules are only required if we process tests with the RELEASE_TESTING
variable set.
* Bumped up Standards-Version to 3.8.4 (no changes).
* Updated d.copyright to follow DEP5 guideline.
* Added /me as Uploaders in d.control.
* Added BDI on libtest-simple-perl (>= 0.88).
* Switch to dpkg-source 3.0 (quilt) format.
2009-10-25 - Jonathan Yu <jawnsy@cpan.org>
libstring-truncate-perl (0.102-1) unstable; urgency=low
* Initial Release (Closes: #552243)

See Also

Package Description
libstring-tt-perl_0.3-1_all.deb Perl module to use TT to interpolate lexical variables
libstringtemplate-java_3.2.1-2_all.deb StringTemplate templating engine for Java
libstroke0-dev_0.5.1-6.1_amd64.deb mouse strokes library -- development files
libstroke0_0.5.1-6.1_amd64.deb mouse strokes library -- runtime files
libstrongswan-extra-plugins_5.2.1-6+deb8u6_amd64.deb strongSwan utility and crypto library (extra plugins)
libstrongswan-standard-plugins_5.2.1-6+deb8u6_amd64.deb strongSwan utility and crypto library (standard plugins)
libstrongswan_5.2.1-6+deb8u6_amd64.deb strongSwan utility and crypto library
libstrophe-dev_0.8.6-1_amd64.deb Library for writing XMPP clients - development files
libstrophe0_0.8.6-1_amd64.deb Library for writing XMPP clients - shared library
libstruct-compare-perl_1.0.1-3_all.deb Perl module providing recursive diff for perl structures
libstruct-dumb-perl_0.03-1_all.deb module to create simple lightweight record-like structures
libstxxl-dev_1.4.0-3_amd64.deb Development libraries for STXXL
libstxxl-doc_1.4.0-3_all.deb Documentation for STXXL
libstxxl1-bin_1.4.0-3_amd64.deb STXXL File creation and benchmark tool
libstxxl1_1.4.0-3_amd64.deb C++ Standard Template Library for extra large datasets
Advertisement
Advertisement