libstring-approx-perl_3.27-1+b2_amd64.deb


Advertisement

Description

libstring-approx-perl - Perl extension for approximate matching (fuzzy matching)

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libstring-approx-perl
Package version: 3.27
Package release: 1+b2
Package architecture: amd64
Package type: deb
Installed size: 164 B
Download size: 39.86 KB
Official Mirror: ftp.br.debian.org
String::Approx lets you match and substitute strings approximately. With this you can emulate errors: typing errors, spelling errors, closely related vocabularies (colour color), genetic mutations (GAG ACT), abbreviations (McScot, MacScot).

Alternatives

    Download

    Source package: libstring-approx-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libstring-approx-perl deb package:
      # sudo apt-get install libstring-approx-perl

    Files

    • /usr/lib/x86_64-linux-gnu/perl5/5.20/String/Approx.pm
    • /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/String/Approx/Approx.so
    • /usr/share/doc/libstring-approx-perl/README.apse
    • /usr/share/doc/libstring-approx-perl/changelog.Debian.amd64.gz
    • /usr/share/doc/libstring-approx-perl/changelog.Debian.gz
    • /usr/share/doc/libstring-approx-perl/changelog.gz
    • /usr/share/doc/libstring-approx-perl/copyright
    • /usr/share/lintian/overrides/libstring-approx-perl
    • /usr/share/man/man3/String::Approx.3pm.gz

    Changelog

    2013-01-23 - Xavier Guimard <x.guimard@free.fr> libstring-approx-perl (3.27-1) unstable; urgency=low * Take over for the Debian Perl Group on maintainer's request (http://bugs.debian.org/677732#10) * Update source format to 3.0 (quilt) * Update debian/copyright (years and format) * Bump Standards-Version to 3.9.4 * Bump debhelper compatibility to 9 to get hardening flags * Update description (Closes: #688482) * Update debian/rules to use "dh $@" * Add spelling-error patch * Add lintian override to hide false-positive hardening warning since hardening flags are really passed to the compiler during build * Update debian/watch to version 3 * Imported Upstream version 3.27 * Remove README and add README.apse in docs * Fix license to Artistic-2 or LGPL-2

    2008-06-03 - Ivan Kohler <ivan-debian@420.am> libstring-approx-perl (3.26-1) unstable; urgency=low * New upstream release

    2005-09-24 - Ivan Kohler <ivan-debian@420.am> libstring-approx-perl (3.25-1) unstable; urgency=low * New upstream release

    2005-01-21 - Ivan Kohler <ivan-debian@420.am> libstring-approx-perl (3.24-1) unstable; urgency=low * New upstream release * Add watch file for uscan

    2004-08-07 - Ivan Kohler <ivan-debian@420.am> libstring-approx-perl (3.23-1) unstable; urgency=low * New upstream release * Change Section: from interpreters to perl * debhelper compat v4

    2002-08-26 - Ivan Kohler <ivan-debian@420.am> libstring-approx-perl (3.19-1) unstable; urgency=low * New upstream release * Rebuild against Perl 5.8.0 * debian/copyright pedantry (closes: Bug#153341, Bug#153384) * bring debian/rules up-to-date with dh-make-perl's rulex.xs

    2001-05-11 - Ivan Kohler <ivan-debian@420.am> libstring-approx-perl (3.14-3) unstable; urgency=low * rebuild for current Perl policy (closes: Bug#95412)

    2001-02-16 - Ivan Kohler <ivan-debian@420.am> libstring-approx-perl (3.14-2) unstable; urgency=low * Removed gratuitous dh_suidregister

    2001-02-02 - Ivan Kohler <ivan-debian@420.am> libstring-approx-perl (3.14-1) unstable; urgency=low * Initial Release.

    Advertisement
    Advertisement