libstrictures-perl_1.005005-1_all.deb


Advertisement

Description

libstrictures-perl - Perl module to turn on strict and make all warnings fatal

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libstrictures-perl
Package version 1.005005
Package release 1
Package architecture all
Package type deb
Installed size 54 B
Download size 13.22 KB
Official Mirror ftp.br.debian.org
strictures turns on strict and makes all warnings fatal. If run within test
cases from VCS checkouts, it will also cause bareword filehandles, indirect
object syntax and multidimensional array emulation to raise a fatal error. To
actually turn on these checks and stop strictures to complain about missing
modules, the recommended packages libbareword-filehandles-perl,
libindirect-perl and libmultidimensional-perl need to be installed.

Alternatives

Package Version Architecture Repository
libstrictures-perl_1.005005-1_all.deb 1.005005 all Debian Main
libstrictures-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libstrictures-perl_1.005005-1_all.deb
Source Package libstrictures-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libstrictures-perl deb package:
    # sudo apt-get install libstrictures-perl

Files

Path
/usr/share/doc/libstrictures-perl/changelog.Debian.gz
/usr/share/doc/libstrictures-perl/changelog.gz
/usr/share/doc/libstrictures-perl/copyright
/usr/share/man/man3/strictures.3pm.gz
/usr/share/perl5/strictures.pm

Changelog

2014-08-23 - Salvatore Bonaccorso <carnil@debian.org>
libstrictures-perl (1.005005-1) unstable; urgency=medium
* Team upload.
* Update Vcs-Browser URL to cgit web frontend
* Imported Upstream version 1.005005
2014-05-14 - Salvatore Bonaccorso <carnil@debian.org>
libstrictures-perl (1.005004-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Axel Beckert ]
* Remove Maximilian Gaß from Uploaders (no more active according to himself)
[ Salvatore Bonaccorso ]
* Imported Upstream version 1.005004
2014-02-16 - Salvatore Bonaccorso <carnil@debian.org>
libstrictures-perl (1.005003-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 1.005003
2013-12-15 - gregor herrmann <gregoa@debian.org>
libstrictures-perl (1.005002-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Convert Suggests into Recommends, following upstream changes.
2013-11-24 - Florian Schlichting <fsfs@debian.org>
libstrictures-perl (1.005001-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Florian Schlichting ]
* Import Upstream version 1.005001
* Email change: Florian Schlichting -> fsfs@debian.org
* Bump years of packaging copyright
* Declare compliance with Debian Policy 3.9.5
2012-12-07 - Salvatore Bonaccorso <carnil@debian.org>
libstrictures-perl (1.004004-1) unstable; urgency=low
* Team upload.
[ Nathan Handler ]
* Email change: Nathan Handler -> nhandler@debian.org
[ Salvatore Bonaccorso ]
* Imported Upstream version 1.004004
2012-09-29 - Salvatore Bonaccorso <carnil@debian.org>
libstrictures-perl (1.004002-1) unstable; urgency=low
* Team upload.
* Imported Upstream version 1.004002
* Bump Standards-Version to 3.9.4
2012-07-19 - Nathan Handler <nhandler@ubuntu.com>
libstrictures-perl (1.004001-1) unstable; urgency=low
* New upstream release
* debian/control: Add myself to list of Uploaders
* debian/copyright: Add myself to debian/* copyright
2012-04-09 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libstrictures-perl (1.003001-1) unstable; urgency=low
* Imported Upstream version 1.003001.
* Dropped disable_extra_tests.patch, fixed upstream.
* Added extra modules to B-D-I and Suggests, and expanded long description
to explain when these are needed.
2012-04-09 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libstrictures-perl (1.003000-1) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Florian Schlichting ]
* Imported Upstream version 1.003000.
* Bumped Standards-Version to 3.9.3 (use copyright-format 1.0).
* Added myself to uploaders and copyright.
* Added disable_extra_tests.patch, we lack build dependencies.

See Also

Package Description
libstrigihtmlgui-dev_0.7.8-1.2+b2_amd64.deb development files for libstrigihtmlgui
libstrigihtmlgui0_0.7.8-1.2+b2_amd64.deb library for writing html clients for Strigi Desktop Search
libstrigiqtdbusclient-dev_0.7.8-1.2+b2_amd64.deb development files for libstrigiqtdbusclient
libstrigiqtdbusclient0_0.7.8-1.2+b2_amd64.deb library for writing D-Bus clients for Strigi Desktop Search
libstring-approx-perl_3.27-1+b2_amd64.deb Perl extension for approximate matching (fuzzy matching)
libstring-bufferstack-perl_1.15-1_all.deb framework for storing nested buffers
libstring-camelcase-perl_0.02-2_all.deb Perl module to convert strings to and from CamelCase
libstring-compare-constanttime-perl_0.310-1_amd64.deb module for protecting string comparison from timing attacks
libstring-crc-cksum-perl_0.91-1_all.deb Perl extension for calculating cksum-compatible checksums
libstring-crc32-perl_1.5-1+b1_amd64.deb Perl interface for cyclic redundancy check generation
libstring-diff-perl_0.06-1_all.deb simple diff for strings
libstring-dirify-perl_1.02-1_all.deb utility converting string to a safe format
libstring-errf-perl_0.007-1_all.deb Perl module that provides a simple sprintf-like dialect
libstring-escape-perl_2010.002-1_all.deb module for manipulating escaped strings
libstring-flogger-perl_1.101245-1_all.deb module to munge strings for loggers
Advertisement
Advertisement