libssh-4_0.6.3-4+deb8u2_amd64.deb


Advertisement

Description

libssh-4 - tiny C SSH library (OpenSSL flavor)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libssh-4
Package version 0.6.3
Package release 4+deb8u2
Package architecture amd64
Package type deb
Installed size 345 B
Download size 125.76 KB
Official Mirror ftp.br.debian.org
The ssh library was designed to be used by programmers needing a working SSH
implementation by the mean of a library. The complete control of the client
is made by the programmer. With libssh, you can remotely execute programs,
transfer files, use a secure and transparent tunnel for your remote programs.
With its SFTP implementation, you can play with remote files easily.
This package contains shared libraries linked against OpenSSL.

Alternatives

Package Version Architecture Repository
libssh-4_0.6.3-4+deb8u2_i386.deb 0.6.3 i386 Debian Main
libssh-4 - - -

Requires

Name Value
libc6 >= 2.15
libgssapi-krb5-2 >= 1.12.1+dfsg-2
libssl1.0.0 >= 1.0.0
multiarch-support -
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package libssh-4_0.6.3-4+deb8u2_amd64.deb
Source Package libssh

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libssh-4 deb package:
    # sudo apt-get install libssh-4

Files

Path
/usr/lib/x86_64-linux-gnu/libssh.so.4
/usr/lib/x86_64-linux-gnu/libssh.so.4.4.1
/usr/lib/x86_64-linux-gnu/libssh_threads.so.4
/usr/lib/x86_64-linux-gnu/libssh_threads.so.4.4.1
/usr/share/doc/libssh-4/README.Debian
/usr/share/doc/libssh-4/changelog.Debian.gz
/usr/share/doc/libssh-4/changelog.gz
/usr/share/doc/libssh-4/copyright
/usr/share/lintian/overrides/libssh-4

Changelog

2016-02-23 - Salvatore Bonaccorso <carnil@debian.org>
libssh (0.6.3-4+deb8u2) jessie-security; urgency=high
* Non-maintainer upload by the Security Team.
* CVE-2016-0739: Truncated Diffie-Hellman secret length (Closes: #815663)
2015-11-23 - Christopher Knadle <Chris.Knadle@coredump.us>
libssh (0.6.3-4+deb8u1) jessie; urgency=medium
* Non-maintainer upload.
* debian/patches:
- Add 0002_CVE-2015-3146.patch
Fix "null pointer dereference due to a logical error in the handling
of a SSH_MSG_NEWKEYS and KEXDH_REPLY packets"
(Closes: #784404, CVE-2015-3146)
2015-01-27 - Laurent Bigonville <bigon@debian.org>
libssh (0.6.3-4) unstable; urgency=medium
* Add debian/patches/0001_CVE-2014-8132.patch: Fixup error path in
ssh_packet_kexinit() (Closes: #773577, CVE-2014-8132)
2014-08-30 - Laurent Bigonville <bigon@debian.org>
libssh (0.6.3-3) unstable; urgency=low
[ Sebastian Ramacher ]
* Build gcrypt flavor. (Closes: #676650)
* d/control:
- Add Build-Dep on libgcrypt-dev.
- Bump Build-Dep on debhelper to >= 9 and remove cdbs.
- Add libssh-gcrypt-dev and libssh-gcrypt-4 packages.
- Add Conflicts to libssh-dev and libssh-gcrypt-dev against each other.
- Add Depends on libssh-gcrypt-4 to libssh-dbg and break incompatible
versions.
- Update libssh-4 and libssh-dev Description.
* d/compat: Bump to 9.
* d/rules: Convert to dh and build gcrypt flavor.
* d/libssh-doc.docs: Update location of documentation.
+ d/patches/1003-custom-lib-names.patch: Allow to overwrite libssh's
OUTPUT_NAME.
[ Laurent Bigonville ]
* debian/libssh-gcrypt-4.lintian-overrides: Add an override for
the dev-pkg-without-shlib-symlink lintian warning
* debian/control, debian/rules: Enable the tests at build time, really
(Closes: #744403)
* debian/control: Add pkg-config to the build-dependencies
* d/p/2003-disable-expand_tilde_unix-test.patch: Disable
torture_path_expand_tilde_unix it's not working well on the buildd
* d/p/0007-security-fix-for-vulnerability-CVE-2014-0017.patch: Drop obsolete
patch, merged upstream in 0.6.3
* debian/rules: Pass -Wl,-z,defs -Wl,-O1 -Wl,--as-needed to the LDFLAGS
* Enable GSSAPI support
- debian/control: Add libkrb5-dev | heimdal-dev to the build-dependencies
- debian/rules: Pass -DWITH_GSSAPI=ON to the CMake flags
- Adjust the .symbols file
2014-05-14 - Mike Gabriel <sunweaver@debian.org>
libssh (0.6.3-2) unstable; urgency=low
[ Mike Gabriel ]
* debian/rules:
+ Enable tests during package build. (Closes: #744403).
2014-05-14 - Mike Gabriel <sunweaver@debian.org>
libssh (0.6.3-1) unstable; urgency=low
* Upload to unstable without changes.
2014-03-05 - Laurent Bigonville <bigon@debian.org>
libssh (0.6.3-1~exp1) experimental; urgency=medium
* New upstream release.
- Reset the PRNG state after accepting a new connection (CVE-2014-0017)
2014-02-19 - Mike Gabriel <sunweaver@debian.org>
libssh (0.6.1-1~exp1) experimental; urgency=low
* New upstream release.
* debian/control:
+ Bump Standards: to 3.9.5. No changes needed.
* debian/patches:
+ Remove obsolete patches (all applied upstream).
+ Add patch for fixing typos in upstream error messages.
* Provide upstream signing key in package.
* Update debian/libssh-4.symbols file.
* Update debian/copyright.in file.
* Update debian/copyright file.
2014-03-05 - Laurent Bigonville <bigon@debian.org>
libssh (0.5.4-3) unstable; urgency=high
[ Mike Gabriel ]
* debian/rules:
+ Add get-orig-source rule.
* debian/watch:
+ Handle tar.gz and tar.xz upstream tarballs alike.
* debian/copyright.in:
+ Ship auto-generated copyright file in debian/ folder.
[ Laurent Bigonville ]
* debian/patches/0007-security-fix-for-vulnerability-CVE-2014-0017.patch:
Reset the PRNG state after accepting a new connection (CVE-2014-0017)

See Also

Package Description
libssh-dev_0.6.3-4+deb8u2_amd64.deb tiny C SSH library. Development files (OpenSSL flavor)
libssh-doc_0.6.3-4+deb8u2_all.deb tiny C SSH library. Documentation files
libssh-gcrypt-4_0.6.3-4+deb8u2_amd64.deb tiny C SSH library (gcrypt flavor)
libssh-gcrypt-dev_0.6.3-4+deb8u2_amd64.deb tiny C SSH library. Development files (gcrypt flavor)
libssh2-1-dev_1.4.3-4.1+deb8u1_amd64.deb SSH2 client-side library (development headers)
libssh2-1_1.4.3-4.1+deb8u1_amd64.deb SSH2 client-side library
libssh2-php_0.12-3+deb8u1_all.deb transitional dummy package for php5-ssh2
libssl-dev_1.0.1t-1+deb8u8_amd64.deb Secure Sockets Layer toolkit - development files
libssl-doc_1.0.1t-1+deb8u8_all.deb Secure Sockets Layer toolkit - development documentation
libssl-ocaml-dev_0.4.7-1_amd64.deb OCaml bindings for OpenSSL
libssl-ocaml_0.4.7-1_amd64.deb OCaml bindings for OpenSSL (runtime)
libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb Secure Sockets Layer toolkit - shared libraries
libssm-dev_1.3-2_amd64.deb macromolecular superposition library - development files
libssm1_1.3-2_amd64.deb macromolecular superposition library - runtime
libssreflect-coq_1.5-2_all.deb small scale reflection library for Coq (theories)
Advertisement
Advertisement