libspatialindex-dev_1.8.1-3_amd64.deb


Advertisement

Description

libspatialindex-dev - General framework for developing spatial indices - development files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libspatialindex-dev
Package version 1.8.1
Package release 3
Package architecture amd64
Package type deb
Installed size 2.27 KB
Download size 298.81 KB
Official Mirror ftp.br.debian.org
Spatialindex is a C++ library that provides a framework for
developing spatial indices. Currently it defines generic interfaces,
provides simple main memory and disk based storage managers and a
robust implementation of an R*-tree, an MVR-tree and a TPR-tree.
This package contains the development files to build third
parties programs.

Alternatives

Package Version Architecture Repository
libspatialindex-dev_1.8.1-3_i386.deb 1.8.1 i386 Debian Main
libspatialindex-dev - - -

Requires

Name Value
libspatialindex-c3 = 1.8.1-3
libspatialindex3 = 1.8.1-3

Download

Type URL
Binary Package libspatialindex-dev_1.8.1-3_amd64.deb
Source Package spatialindex

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libspatialindex-dev deb package:
    # sudo apt-get install libspatialindex-dev

Files

Path
/usr/include/spatialindex/LineSegment.h
/usr/include/spatialindex/MVRTree.h
/usr/include/spatialindex/MovingPoint.h
/usr/include/spatialindex/MovingRegion.h
/usr/include/spatialindex/Point.h
/usr/include/spatialindex/RTree.h
/usr/include/spatialindex/Region.h
/usr/include/spatialindex/SpatialIndex.h
/usr/include/spatialindex/TPRTree.h
/usr/include/spatialindex/TimePoint.h
/usr/include/spatialindex/TimeRegion.h
/usr/include/spatialindex/Version.h
/usr/include/spatialindex/capi/BoundsQuery.h
/usr/include/spatialindex/capi/CountVisitor.h
/usr/include/spatialindex/capi/CustomStorage.h
/usr/include/spatialindex/capi/DataStream.h
/usr/include/spatialindex/capi/Error.h
/usr/include/spatialindex/capi/IdVisitor.h
/usr/include/spatialindex/capi/Index.h
/usr/include/spatialindex/capi/LeafQuery.h
/usr/include/spatialindex/capi/ObjVisitor.h
/usr/include/spatialindex/capi/Utility.h
/usr/include/spatialindex/capi/sidx_api.h
/usr/include/spatialindex/capi/sidx_config.h
/usr/include/spatialindex/capi/sidx_impl.h
/usr/include/spatialindex/tools/PointerPool.h
/usr/include/spatialindex/tools/PoolPointer.h
/usr/include/spatialindex/tools/SmartPointer.h
/usr/include/spatialindex/tools/Tools.h
/usr/include/spatialindex/tools/rand48.h
/usr/lib/x86_64-linux-gnu/libspatialindex.a
/usr/lib/x86_64-linux-gnu/libspatialindex.so
/usr/lib/x86_64-linux-gnu/libspatialindex_c.a
/usr/lib/x86_64-linux-gnu/libspatialindex_c.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libspatialindex.pc
/usr/share/doc/libspatialindex-dev/changelog.Debian.gz
/usr/share/doc/libspatialindex-dev/changelog.gz
/usr/share/doc/libspatialindex-dev/copyright

Changelog

2014-09-28 - Bas Couwenberg <sebastic@xs4all.nl>
spatialindex (1.8.1-3) unstable; urgency=medium
* Add gbp.conf to use pristine-tar by default.
* Drop lintian override for debian-watch-may-check-gpg-signature,
shouldn't override pedantic tags.
* Update pkgconfig.patch to not include build flags.
2014-01-12 - Bas Couwenberg <sebastic@xs4all.nl>
spatialindex (1.8.1-2) unstable; urgency=low
* Update pkg-config patch to remove LDFLAGS from Libs.
(closes: #735039)
2014-01-10 - Bas Couwenberg <sebastic@xs4all.nl>
spatialindex (1.8.1-1) unstable; urgency=low
* New upstream release.
* Add myself to Uploaders.
* Update watch file including sepwatch changes.
* Update Homepage to github documentation instead of code.
* Use canonical URLs in Vcs-* fields.
* Change priority from extra to optional.
* Bump debhelper compatibility to 9.
* Use minimal dh rules with dh-autoreconf.
(closes: #734827, #722835)
* Support Multi-Arch build.
* Add misc:Depends for libspatialindex-dev.
* Don't start description synopsis with an article.
* Change library packages to match SONAME, and use correct description.
(closes: #642482)
* Add debug package for the shared library.
* Update copyright file using copyright-format 1.0.
* Add lintian override for debian-watch-may-check-gpg-signature,
upstream doesn't provide signatures for verification.
* Remove .la files before install.
* Add symbols files using pkgkde-symbolshelper.
* Bump Standards-Version to 3.9.5, changes: minimal dh rules, Multi-Arch,
Vcs-* fields, shared library changes, copyright.
* Add patch to modernize the build system.
* Add patch to include linking to libspatialindex in pkg-config file.
(closes: #679690)
2011-11-28 - Francesco Paolo Lovergine <frankie@debian.org>
spatialindex (1.7.0-1) unstable; urgency=low
* New upstream release.
* Changed homepage in debian/control.
* Policy bumped to 3.9.2.
* Moved to debian source 3.0 and quilt support.
* Moved to git repository and changed Vcs-* fields as consequence.
* Now using debhelper 8 as minimal level.
* Now save and restore config.* helpers.
* Now do not install libtool helper file and adds a pkg-config configuration
file instead.
2011-11-28 - Francesco Paolo Lovergine <frankie@debian.org>
spatialindex (1.5.0-1) unstable; urgency=low
* New upstream release. 
2009-09-12 - Francesco Paolo Lovergine <frankie@debian.org>
spatialindex (1.4.0-1) unstable; urgency=low
* New upstream release.
* Partch gcc43 removed, because merged upstream.
* Policy bumped to 3.8.3, without changes.
2009-05-27 - Francesco Paolo Lovergine <frankie@debian.org>
spatialindex (1.3.2-1) unstable; urgency=low
* Initial release.
(closes: #530845)

See Also

Package Description
libspatialindex3_1.8.1-3_amd64.deb General framework for developing spatial indices
libspatialite-dev_4.1.1-10_amd64.deb Geospatial extension for SQLite - development files
libspatialite5_4.1.1-10_amd64.deb Geospatial extension for SQLite - libraries
libspctag-dev_0.2-1_amd64.deb ID666 tags edition support library (development headers)
libspctag1_0.2-1_amd64.deb ID666 tags edition support library
libspectre-dev_0.2.7-3_amd64.deb Library for rendering PostScript documents - development files
libspectre1_0.2.7-3_amd64.deb Library for rendering PostScript documents
libspectrum-dev_1.1.1-1+b1_amd64.deb ZX Spectrum emulator library - Development files
libspectrum8_1.1.1-1+b1_amd64.deb ZX Spectrum emulator library - Shared libraries
libspeechd-dev_0.8-7_amd64.deb Speech Dispatcher: Development libraries and header files
libspeechd2_0.8-7_amd64.deb Speech Dispatcher: Shared libraries
libspeex-dev_1.2~rc1.2-1_amd64.deb The Speex codec library development files
libspeex-ocaml-dev_0.2.0-3+b1_amd64.deb OCaml interface to the speex library
libspeex-ocaml_0.2.0-3+b1_amd64.deb OCaml interface to the speex library
libspeex1_1.2~rc1.2-1_amd64.deb The Speex codec runtime library
Advertisement
Advertisement