libsms-send-perl_1.06-2_all.deb


Advertisement

Description

libsms-send-perl - driver-based API for sending SMS messages

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libsms-send-perl
Package version 1.06
Package release 2
Package architecture all
Package type deb
Installed size 34 B
Download size 21.12 KB
Official Mirror ftp.br.debian.org
The SMS::Send perl module is intended to provide a driver-based single API for
sending SMS and MMS messages. The intent is to provide a single API against
which to write the code to send an SMS message.
At the same time, the intent is to remove the limits of some of the
previous attempts at this sort of API, like "must be free internet-based
SMS services".
SMS::Send drivers are installed separately, and might use the web,
email or physical SMS hardware. It could be a free or paid. The details
shouldn't matter.
You should not have to care how it is actually sent, only that it has
been sent (although some drivers may not be able to provide certainty).

Alternatives

Package Version Architecture Repository
libsms-send-perl_1.06-2_all.deb 1.06 all Debian Main
libsms-send-perl - - -

Requires

Name Value
libclass-adapter-perl -
libmodule-pluggable-perl -
libparams-util-perl -
perl -
perl << 5.17.0

Download

Type URL
Binary Package libsms-send-perl_1.06-2_all.deb
Source Package libsms-send-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsms-send-perl deb package:
    # sudo apt-get install libsms-send-perl

Files

Path
/usr/share/doc/libsms-send-perl/changelog.Debian.gz
/usr/share/doc/libsms-send-perl/changelog.gz
/usr/share/doc/libsms-send-perl/copyright
/usr/share/man/man3/SMS::Send.3pm.gz
/usr/share/man/man3/SMS::Send::AU::Test.3pm.gz
/usr/share/man/man3/SMS::Send::Driver.3pm.gz
/usr/share/man/man3/SMS::Send::Test.3pm.gz
/usr/share/perl5/SMS/Send.pm
/usr/share/perl5/SMS/Send/Driver.pm
/usr/share/perl5/SMS/Send/Test.pm
/usr/share/perl5/SMS/Send/AU/Test.pm

Changelog

2014-06-10 - Damyan Ivanov <dmn@debian.org>
libsms-send-perl (1.06-2) unstable; urgency=low
* Team upload
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Explicitly (build-)depend on Module::Pluggable. (Closes: #711673)
* Strip trailing slash from metacpan URLs.
[ Damyan Ivanov ]
* Declare conformance with Policy 3.9.5
2012-04-07 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libsms-send-perl (1.06-1) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Harlan Lieberman-Berg ]
* New upstream version (1.06).
* Remove unnecessary README.source describing dquilt.
* Bump d/compat to 8.
* Cleaned up d/copyright for DEP-5 compliance.
* Add d/source/format
* Change dependencies around a bit.
* Use dh for everything in d/rules.
* Remove unnecessary patch.
* Add patch to correct minor manpage misspelling.
[ Florian Schlichting ]
* Fix various TODO items.
* Remove version from Perl and Class::Adapter (build) dependencies.
* Bump years of upstream copyright.
* Bump Standards-Version to 3.9.3 (use copyright-format 1.0).
* Add myself to Uploaders and copyright.
2009-03-28 - gregor herrmann <gregoa@debian.org>
libsms-send-perl (0.05-2) unstable; urgency=low
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* Add patch require_perl.patch that bumps the required perl version in
META.yml, thanks to Marco Rodrigues for the bug report (closes: #521580).
* Add /me to Uploaders.
* Set Standards-Version to 3.8.1 (no changes).
* debian/copyright: switch to new format.
2008-08-15 - Vincent Danjean <vdanjean@debian.org>
libsms-send-perl (0.05-1) unstable; urgency=low
* Initial release. (Closes: #495218: ITP: libsms-send-perl -- Driver-
based API for sending SMS messages)

See Also

Package Description
libsnacc-dev_1.3.1-5_amd64.deb ASN.1 to C or C++ or IDL compiler, development files
libsnacc0c2_1.3.1-5_amd64.deb ASN.1 to C or C++ or IDL compiler, shared libraries
libsnack-alsa_2.2.10.20090623-dfsg-4_amd64.deb Sound extension to Tcl/Tk and Python/Tkinter - ALSA files
libsnack-oss_2.2.10.20090623-dfsg-4_amd64.deb Sound extension to Tcl/Tk and Python/Tkinter - OSS files
libsnapper-dev_0.2.4-1_amd64.deb Library for Linux filesystem snapshot management tool (header files)
libsnapper2_0.2.4-1_amd64.deb Library for Linux filesystem snapshot management tool
libsnappy-dev_1.1.2-3_amd64.deb fast compression/decompression library (development files)
libsnappy1.0.3-java_1.0.3-rc3~dfsg-4_all.deb Snappy v1.0.3 for Java, a fast compressor/decompresser
libsnappy1_1.1.2-3_amd64.deb fast compression/decompression library
libsndfile1-dev_1.0.25-9.1+deb8u1_amd64.deb Development files for libsndfile; a library for reading/writing audio files
libsndfile1_1.0.25-9.1+deb8u1_amd64.deb Library for reading/writing audio files
libsndobj-dev_2.6.6.1-3_amd64.deb Sound Object library (development files)
libsndobj2c2_2.6.6.1-3_amd64.deb Sound Object library
libsnmp-base_5.7.2.1+dfsg-1+deb8u1_all.deb SNMP configuration script, MIBs and documentation
libsnmp-dev_5.7.2.1+dfsg-1+deb8u1+b1_amd64.deb SNMP (Simple Network Management Protocol) development files
Advertisement
Advertisement