libshout3-dev - MP3/Ogg Vorbis broadcast streaming library (development)

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libshout3-dev
Package version: 2.3.1
Package release: 3
Package architecture: amd64
Package type: deb
Installed size: 187 B
Download size: 50.08 KB
Official Mirror:
A library for communicating with and sending data to Icecast and Icecast 2 streaming audio servers. It handles the socket connection, the timing of the data transmission, and prevents bad data from getting to the server. With just a few lines of code, a programmer can easily turn any application into a streaming source for an Icecast-based server. Libshout also allows developers who want a specific feature set (database access, request taking) to concentrate on that feature set, instead of worrying about how server communication works. This package contains the development headers, static libraries, and source code to an example program.



  • libshout-dev


  • libshout-dev


    Source package: libshout

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libshout3-dev deb package:
      # sudo apt-get install libshout3-dev


    • /usr/include/shout/shout.h
    • /usr/lib/x86_64-linux-gnu/libshout.a
    • /usr/lib/x86_64-linux-gnu/
    • /usr/lib/x86_64-linux-gnu/pkgconfig/shout.pc
    • /usr/share/aclocal/shout.m4
    • /usr/share/doc/libshout3-dev/NEWS.gz
    • /usr/share/doc/libshout3-dev/README
    • /usr/share/doc/libshout3-dev/buildinfo_amd64.gz
    • /usr/share/doc/libshout3-dev/changelog.Debian.gz
    • /usr/share/doc/libshout3-dev/copyright
    • /usr/share/doc/libshout3-dev/examples/example.c


    2013-05-09 - Jonas Smedegaard <> libshout (2.3.1-3) unstable; urgency=low * Bump dephelper compatibility level to 8. * Use URL for Vcs-Git. * Bump policy compliance to standards-version 3.9.4.

    2013-05-09 - Jonas Smedegaard <> libshout (2.3.1-2) experimental; urgency=low * Drop unneeded build-dependency on libopus-dev. * Update copyright file: + Fix add Files section for opus.c: New copyright holder, same licensing as main project. + Bump packaging license to GPL-3+. + Extend coverage of packaging to include recent years. * Ensure order of library install targets. Thanks to Vasudev Kamath. * Update package relations: + Fix pre-depend on multiarch-support only for lib package. + Build-depend (again) on dh-buildinfo: Multiarch-compliant nowadays. + Build-depend (again) on devscripts: No longer complicates backporting. + Tighten build-dependency on cdbs: Needed for simplified cruft handing. * Update README.source to emphasize file as *not* a show-stopper for contributions, referring to wiki page for details. * Simplify watch file. * Simplify rules file, using CDBS DEB_UPSTREAM_CRUFT_MOVE.

    2012-06-05 - Jonas Smedegaard <> libshout (2.3.1-1) experimental; urgency=low * New upstream release. + Opus support. * Build-depend on libopus-dev. * Thanks to Ron Lee for coordinating this release.

    2012-03-25 - Jonas Smedegaard <> libshout (2.3.0-1) experimental; urgency=low * New upstream release. * Bump standards-version to 3.9.3. * Use URL in Vcs-Browser field. * Simplify install path, thanks to debhelper compatibility level 7. * Update copyright file: + Bump format to 1.0. + Fix double-indent in Copyright fields as per Policy §5.6.13. + Extend copyright years. + Include disclaimers in GAP licenses. * Update package relations: + Relax build-depend unversioned on debhelper: Needed version satisfied even in oldstable. * Improve multiarch quirks to ease backporting. * Update patches: + Drop patch 1002 to link against libspeex: Applied upstream. + Change patch 1001 to apply to master autotools files (not autogenerated ones). + Refresh patch 1003 with shortening quilt options. + Add DEP3 patch headers. * Autogenerate autotools during build.

    2012-02-15 - Alessio Treglia <> libshout (2.2.2-8) unstable; urgency=low * Team upload. [ Alessio Treglia ] * Introduce MultiArch support. Thanks to Steve Langasek for the original patch: (Closes: #652504) - debian/control: + Bump cdbs minimum requirement to 0.4.93~. + Don't build-depend on dh-buildinfo, which is non multiarch-safe. + Regenerate. - debian/rules: + Move pkgconfig files into multiarch path. + Don't set DH_COMPAT in debian/rules. [ Jonas Smedegaard ] * Add README.source, documenting use of git-buildpackage and CDBS (replacing README.cdbs-tweaks).