libschedule-ratelimiter-perl_0.01-1_all.deb


Advertisement

Description

libschedule-ratelimiter-perl - Perl library to prevent events from happening too quickly

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libschedule-ratelimiter-perl
Package version 0.01
Package release 1
Package architecture all
Package type deb
Installed size 68 B
Download size 9.91 KB
Official Mirror ftp.br.debian.org
Schedule::RateLimiter provides a way to voluntarily restrict how many times a
given action may take place within a specified time frame. Such a tool may be
useful if you have written something which periodically polls some public
resource and want to ensure that you do not overburden that resource with too
many requests.
Initially, one might think that solving this problem would be as simple as
sleeping for the number of seconds divided by the number of iterations in
between each event. However, that would only be correct if the event took no
time at all.
If you know exactly how much time each event is going to take then you could
build an even more complicated one-liner such as this:
sleep( (seconds / iterations) - single_event_time )

Alternatives

Package Version Architecture Repository
libschedule-ratelimiter-perl_0.01-1_all.deb 0.01 all Debian Main
libschedule-ratelimiter-perl - - -

Requires

Name Value
perl >= 5.6.0-16

Download

Type URL
Binary Package libschedule-ratelimiter-perl_0.01-1_all.deb
Source Package libschedule-ratelimiter-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libschedule-ratelimiter-perl deb package:
    # sudo apt-get install libschedule-ratelimiter-perl

Files

Path
/usr/share/doc/libschedule-ratelimiter-perl/README
/usr/share/doc/libschedule-ratelimiter-perl/changelog.Debian.gz
/usr/share/doc/libschedule-ratelimiter-perl/changelog.gz
/usr/share/doc/libschedule-ratelimiter-perl/copyright
/usr/share/man/man3/Schedule::RateLimiter.3pm.gz
/usr/share/perl5/Schedule/RateLimiter.pm

Changelog

2009-03-05 - Ryan Niebur <ryanryan52@gmail.com>
libschedule-ratelimiter-perl (0.01-1) unstable; urgency=low
* Initial Release. (Closes: #518443)

See Also

Package Description
libschroedinger-1.0-0_1.0.11-2.1_amd64.deb library for encoding/decoding of Dirac video streams
libschroedinger-dev_1.0.11-2.1_amd64.deb library for encoding/decoding of Dirac video streams (development files)
libschroedinger-doc_1.0.11-2.1_all.deb library for encoding/decoding of Dirac video streams (documentation)
libschroedinger-ocaml-dev_0.1.0-3+b1_amd64.deb OCaml interface to the schroedinger library -- developpement files
libschroedinger-ocaml_0.1.0-3+b1_amd64.deb OCaml interface to the schroedinger library -- runtime files
libscim-dev_1.4.15-3_amd64.deb development library for SCIM platform
libscim8c2a_1.4.15-3_amd64.deb library for SCIM platform
libscm-dev_5e5-3.3_amd64.deb Embeddable library for SCM Scheme language interpreter
libscope-guard-perl_0.20-1_all.deb lexically scoped resource management
libscope-upper-perl_0.25-1_amd64.deb module to manipulate upper scopes
libscotch-5.1_5.1.12b.dfsg-2+b1_amd64.deb programs and libraries for graph, mesh and hypergraph partitioning
libscotch-dev_5.1.12b.dfsg-2+b1_amd64.deb programs and libraries for graph, mesh and hypergraph partitioning
libscotchmetis-dev_5.1.12b.dfsg-2+b1_amd64.deb programs and libraries for graph, mesh and hypergraph partitioning
libscotchparmetis-dev_5.1.12b.dfsg-2+b1_amd64.deb programs and libraries for graph, mesh and hypergraph partitioning
libscout-clojure_0.1.1-2_all.deb Clojure library to parse strings
Advertisement
Advertisement