libsane-perl_0.05-2+b2_amd64.deb


Advertisement

Description

libsane-perl - Perl bindings for the SANE (Scanner Access Now Easy) Project

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libsane-perl
Package version 0.05
Package release 2+b2
Package architecture amd64
Package type deb
Installed size 128 B
Download size 27.56 KB
Official Mirror ftp.br.debian.org
The Sane module allows you to access SANE-compatible scanners in a Perlish
and object-oriented way, freeing you from the casting and memory management
in C, yet remaining very close in spirit to original API.

Alternatives

Package Version Architecture Repository
libsane-perl_0.05-2+b2_i386.deb 0.05 i386 Debian Main
libsane-perl - - -

Requires

Name Value
libc6 >= 2.4
libsane >= 1.0.19
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libsane-perl_0.05-2+b2_amd64.deb
Source Package libsane-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsane-perl deb package:
    # sudo apt-get install libsane-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Sane.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Sane/Sane.so
/usr/share/doc/libsane-perl/changelog.Debian.amd64.gz
/usr/share/doc/libsane-perl/changelog.Debian.gz
/usr/share/doc/libsane-perl/changelog.gz
/usr/share/doc/libsane-perl/copyright
/usr/share/man/man3/Sane.3pm.gz

Changelog

2012-05-21 - Jeffrey Ratcliffe <jjr@debian.org>
libsane-perl (0.05-2) unstable; urgency=low
* Disable tests
Closes: #626019 (FTBFS on various architectures (hanging tests?))
2012-04-08 - Jeffrey Ratcliffe <jjr@debian.org>
libsane-perl (0.05-1) unstable; urgency=low
* New upstream release
2012-02-15 - Salvatore Bonaccorso <carnil@debian.org>
libsane-perl (0.04-1) unstable; urgency=low
* Team upload.
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.04
+ Checks for opt->size=0 and zero-length data (LP: #930552).
* Update debian/copyright file.
Update Format to revision 174 of DEP5 proposal for machine-readable
copyright file information.
Update copyright years.
Add explicit License stanzas for Artistic and GPL-1+ license.
Refer to the GPL-1 license text in /usr/share/common-licenses/GPL-1.
* Simplify debian/rules to a three line tiny makefile
* Bump Debhelper compat level to 9.
Adjust Build-Depends on debhelper to debhelper (>= 9).
* Bump Standards-Version to 3.9.2
* Convert to '3.0 (quilt)' source package format
2009-05-11 - Jeffrey Ratcliffe <Jeffrey.Ratcliffe@gmail.com>
libsane-perl (0.03-1) unstable; urgency=low
[ Jeffrey Ratcliffe ]
* New upstream release
Closes: #527695:
(libsane-perl: FTBFS: Sane.xs:372: error: 'SANE_CAP_ALWAYS_SETTABLE'...)
[ gregor herrmann ]
* debian/control:
- add Homepage field
- add libtest-pod-perl to Build-Depends
- remove base-files (>= 4.0.0) from Depends (base-files is essential, and
even oldstable has version 4)
2008-11-25 - Jeffrey Ratcliffe <Jeffrey.Ratcliffe@gmail.com>
libsane-perl (0.02-1) unstable; urgency=low
* Initial release (Closes: #506405).

See Also

Package Description
libsane_1.0.24-8+deb8u2_amd64.deb API library for scanners
libsanlock-client1_2.2-2_amd64.deb shared storage lock manager (client library)
libsanlock-dev_2.2-2_amd64.deb shared storage lock manager (development files)
libsasl2-2_2.1.26.dfsg1-13+deb8u1_amd64.deb Cyrus SASL - authentication abstraction library
libsasl2-dev_2.1.26.dfsg1-13+deb8u1_amd64.deb Cyrus SASL - development files for authentication abstraction library
libsasl2-modules-db_2.1.26.dfsg1-13+deb8u1_amd64.deb Cyrus SASL - pluggable authentication modules (DB)
libsasl2-modules-gssapi-heimdal_2.1.26.dfsg1-13+deb8u1_amd64.deb Pluggable Authentication Modules for SASL (GSSAPI)
libsasl2-modules-gssapi-mit_2.1.26.dfsg1-13+deb8u1_amd64.deb Cyrus SASL - pluggable authentication modules (GSSAPI)
libsasl2-modules-ldap_2.1.26.dfsg1-13+deb8u1_amd64.deb Cyrus SASL - pluggable authentication modules (LDAP)
libsasl2-modules-otp_2.1.26.dfsg1-13+deb8u1_amd64.deb Cyrus SASL - pluggable authentication modules (OTP)
libsasl2-modules-sql_2.1.26.dfsg1-13+deb8u1_amd64.deb Cyrus SASL - pluggable authentication modules (SQL)
libsasl2-modules_2.1.26.dfsg1-13+deb8u1_amd64.deb Cyrus SASL - pluggable authentication modules
libsatmr3-dev_1.1.4-4.2_amd64.deb Standards-based cluster framework (TMR developer files)
libsatmr3_1.1.4-4.2_amd64.deb Standards-based cluster framework (TMR libraries)
libsaxon-java-doc_6.5.5-10_all.deb Saxon XSLT Processor's documentation and javadoc
Advertisement
Advertisement