librun-parts-perl_0.08-1_all.deb


Advertisement

Description

librun-parts-perl - Offers run-parts' functionality in Perl

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: librun-parts-perl
Package version: 0.08
Package release: 1
Package architecture: all
Package type: deb
Installed size: 73 B
Download size: 18.91 KB
Official Mirror: ftp.br.debian.org
run-parts and hence Run::Parts runs all the executable files named within constraints described below, found in the given directory. Other files and directories are silently ignored. Additionally they can just print the names of the all matching files (not limited to executables, but ignores blacklisted files like e.g. backup files), but don't actually run them. Run::Parts contains two backend implementation. Run::Parts::Debian actually uses /bin/run-parts and Run::Parts::Perl is a pure Perl implementation of a basic set of run-parts' functionality. On Debian Run::Parts uses Run::Parts::Debian by default. But you can also choose any of the backends explicitly.

Alternatives

    Download

    Source package: librun-parts-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install librun-parts-perl deb package:
      # sudo apt-get install librun-parts-perl

    Files

    • /usr/share/doc/librun-parts-perl/README
    • /usr/share/doc/librun-parts-perl/changelog.Debian.gz
    • /usr/share/doc/librun-parts-perl/changelog.gz
    • /usr/share/doc/librun-parts-perl/copyright
    • /usr/share/man/man3/Run::Parts.3pm.gz
    • /usr/share/man/man3/Run::Parts::Common.3pm.gz
    • /usr/share/man/man3/Run::Parts::Debian.3pm.gz
    • /usr/share/man/man3/Run::Parts::Perl.3pm.gz
    • /usr/share/perl5/Run/Parts.pm
    • /usr/share/perl5/Run/Parts/Common.pm
    • /usr/share/perl5/Run/Parts/Debian.pm
    • /usr/share/perl5/Run/Parts/Perl.pm

    Changelog

    2014-09-11 - Axel Beckert <abe@debian.org> librun-parts-perl (0.08-1) unstable; urgency=medium * New upstream release

    2014-09-10 - Axel Beckert <abe@debian.org> librun-parts-perl (0.07-1) unstable; urgency=low * New upstream release. + Drop build-dependency on libmodule-build-perl. + Add new build dependencies on libtest-{trap,warnings}-perl. * Remove trailing slash from metacpan.org URLs, use HTTPS.

    2013-10-28 - Axel Beckert <abe@debian.org> librun-parts-perl (0.06-1) unstable; urgency=low * New upstream release (docs, build-system and test-suite changes only) + Add versioned build-dependency on libmodule-build-perl >= 0.400400 since 0.4003 as shipped with Perl 5.18.1 does not suffice. * Bump Standards-Version to 3.9.5 (no changes)

    2013-07-10 - Axel Beckert <abe@debian.org> librun-parts-perl (0.04-1) unstable; urgency=low * New upstream release. * Add new (build-) dependencies: + libexporter-easy-perl + libfile-slurp-perl + libmodern-perl-perl + libtest-nowarnings-perl (build-dependency only)

    2013-07-06 - Axel Beckert <abe@debian.org> librun-parts-perl (0.03-1) unstable; urgency=low * Initial Release. (Closes: #714969)

    Advertisement
    Advertisement